iPXE discussion forum

Full Version: iPXE, Wimboot, and Dell R630
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm using wimboot to install windows 2012 R2 and windows 2016. It works perfectly for everything so far except for some reason with Dell R630's I get a BSOD without an error code, and it is the same for both versions of Windows. I've tried everything from injecting drivers to boot.wim, to changing bios settings like enabling legacy video, I've tried the original BCD file, as well as editing it. Nothing seems to have worked. Has anyone else run into this issue?

Basic information is missing - what is the bluescreen? run non automatic reboot mode and make sure to get the actual messages and codes from the bluescreen

Also test original boot.wim from installation media (because drivers can be the issue if you have modified it) and also test that boot.wim from a usb drive and make sure that works, before we assume that it is at all related to the use of wimboot.
As stated earlier, there is no stop code. Just "system thread exception not handled". I was getting the error from the stock boot.wim, as well as after trying to inject drivers. The same error every time. I've even pulled the boot.wim from the iso directly. The ISO installs fine, so I tried grabbing drivers from the installed OS on the Dell R630 which also did not work. It works fine on the R620, I just can't seem to find what is different.

I've tried uploading a screenshot but I keep getting an error saying to use a valid file.

Uploads is not supported here, post the image elsewhere and link it in.

All bluescreens always have stop code and/or error name I guess that "system thread exception not handled" is actually SYSTEM_THREAD_EXCEPTION_NOT_HANDLED ?

Here is one suggested fix, even if it relates to vmware it can be worth a shot.. http://forum.ipxe.org/showthread.php?tid...9#pid12789 (it relates to issues with multiple CPUs and maybe it is a firmware issue)

Also could you please verify which version of wimboot you are using? And maybe also how you start wimboot and which driver is shown in iPXE when running ifstat.

And again adding drivers can _only_ make it worse! my suggestion is to never add drivers to boot.wim unless you need it for network. if disk drivers is needed only load it with loaddrv after winpe has started.
Ahh thank you! I just needed the latest Wimboot. That worked just fine.
(2017-08-04 00:31)charlesjenness Wrote: [ -> ]Ahh thank you! I just needed the latest Wimboot. That worked just fine.

So which version did you run before?
I was using wimboot 2.5.2 which I downloaded when I set the system up.
Reference URL's