iPXE discussion forum

Full Version: Problem connecting to iSCSI target
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This is probably a stupid newbie problem, but I'm stuck anyway, so perhaps someone can point me to the right direction...

I am trying to mount an iSCSI-volume located on a windows Server ( I am using an iPXE USB stick I created as per instructions.
I am using a machine that has a disk with windows 7 attached so I tried to acces the volume using MS iSCSI Initiator using the iqn:

This way I could connect and use that volume.

Then I started the same machine from the iPXE-USB stick and did:
iPXE> dhcp
DHCP (net0 .......).....ok
iPXE> sanhook iscsi:
Could not open SAN device: No such device (http://....)

I am not using any PAP/CHAP authentication and I am using the IP-address as initiator name in the iSCSI target definition.
I used the config-command to make sure I get proper IP-information. I even tried setting the root path option in dhcp - I get that information on the iPXE client but I still cannot boot.

Any ideas what I am doing wrong here??


I have my boot_script.php as this.

dhcp net0
sanhook iscsi:

But it does not connect the SAN device.

If I hit CTL-B from iPXE and manually type the commands it fails with "Could not open SAN device: connection timed out"

Am I missing something in the script? Does typing maually act differently?


EDIT: Wow. I almost made sense. Please disregard my gibberish. I found MY error and everything is working.
Are you sure that you have allowed ipxe (with its initiator-iqn) to actually connect to the iSCSI target? First verify that you can connect to it with another client (e.g. Microsoft iSCSI client). Then you need to ensure the target is available for the specific initiator-iqn ipxe sends out. It is org.ipxe.something... I think you can find out the exact one by using the config command in ipxe shell. You can also do a wireshark trace and see the initiator-iqn used in the packet.

If all this fails, you might've found a bug that stops it from working. I'm going to assume that booting normal boot images works as expected?
Reference URL's