iPXE discussion forum

Full Version: FAQ - Frequently Asked Questions
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This thread is used to keep a list of the more common questions asked in the different communication channels we have for iPXE.

If you have additions or other suggestions for what should go in here, please discuss it here.



I tried to register a user earlier, and now that I've returned it says I'm a spammer. How can I get my user registration fixed so I can post?

You got classified as a spammer because we have an insane amount of spammy user registrations every single day. If you register, but don't post anything you'll most likely be identified as a spammer. To avoid being identified as a spammer, don't register until you're ready to post your question. If you've already been identified as a spammer, please contact the forum administrator and explain that your iPXE forum account was misclassified as a spammer. Please include your email and/or your user name so that we can reinstate your posting privileges.

I registered and posted a question, but I can't see it anywhere. Where is my post?

First time posters will have their messages moderated until at least one message is approved by a moderator. Once that first post has been approved you'll be free to post as much as you want without moderation. We've had to go to this extreme to protect the forum against spammers.

How long does it take for my first post to be moderated?

iPXE is not a very large project, and this forum has very few moderators. At best your post might be moderated the same day, at worst it could take up to a couple of weeks. The average time is usually 3-4 days.



How do I boot the Windows ISO from HTTP and install to an iSCSI volume?

Use wimboot to boot the files extracted from the Windows ISO. The WinPE howto includes instructions for creating an installation share and running the installer.



How do I build ipxelinux.0?

See this protip on coderwall. Just be aware that you don't really need to keep them embedded together. They work just as well apart as together.



After booting the Windows installer with a SAN drive hooked, my SAN drive isn't appearing in disk manager, or it is very slow. How can I fix this?

The most likely reason you can't see the SAN disk, or it is very slow, is because the iBFT contains a pointer to your default gateway which Windows uses to create a static route to your iSCSI server. If your router has a slow network interface, or doesn't have a correct setup to send traffic to local machines back onto the local network, you will experience one (or both) of the problems mentioned above.

If your iSCSI target server is on the same subnet as your client, you should be able to fix this problem by not providing a default gateway during the iPXE boot process.

The simplest way to do this is to put the command set netX/gateway 0.0.0.0 right before the sanhook command in your iPXE script.

Alternatively, if you're using chainloading, you can unset the default gateway in the host/range block within the iPXE user-class block. It'd be something like this:

Code:
if exists user-class and option user-class = "iPXE" {
    option root-path "iscsi:iscsi.example.com::::iqn.1992-01.com.example.iscsi:target";
    option routers 0.0.0.0;
} else {
    filename "undionly.kpxe";
}



How do I install Windows 7 to an iSCSI target/volume?

You basically follow the instructions in http://ipxe.org/howto/winpe and add a sanhook command before you start wimboot. Adam has written up a short tutorial here.



How do I install Windows 8.1 using wimboot?

The bootmgr file located at the root of the winpe.iso file for Windows 8.1 can't be unpacked by wimboot 1.0.3. You'll need to use bootmgr.exe which can be found at winpe.iso\SOURCES\BOOT.WIM\Windows\Boot\PXE\bootmgr.exe. You'll need to unpack both winpe.iso and boot.wim. 7-zip usually works well for that. This has been fixed in wimboot 2.2.0. We recommend that you use the automatic unpacking of bootmgr.exe from the .wim feature instead of specifying bootmgr in your iPXE script.
Reference URL's