iPXE discussion forum

Full Version: Comstar iSCSI read error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm trying to set up a diskless server for multiple linux distributions. My back end storage is nexentastor which uses the comstar iscsi target along with zfs (from my understanding it's basically just like opensolaris 11).

Basically, I made a 200GB zvol which I exported via iscsi and loaded centos on via the advanced storage feature in the centos installer. I also tried a gentoo install without success.

My head node is linux which runs dhcp/tftp and serves the undionly.ipxe file. I can load up this file but I try to boot into the iscsi target via direct ethernet connection and I get:

iPXE> sanboot iscsi:<iscsi target>
Registered SAN device 0x80
Booting from SAN device 0x80
Read Error


I also tried sanhook and then the --drive 0x80 along with
various other permutations.

I've also tried importing the comstar iscsi target into the linux machine with iscsiadm and then just exporting the device via tgtadm. That too I get this error.

Has anyone encountered this or have any insight as to the issue at hand? I don't get a nice error with a url. If it helps, I'm using virutalbox as my client at the moment and I can import the iscsi disc with virtualbox as a local disc and then boot up (if I do the solaris comstar -> linux tgtadm setup).

Thanks in advance for any assistance.
You might have a problem with the ACLs on that volume. Look carefully at the outputs of the various itadm and stfmadm commands. I believe the initiator-iqn of ipxe is not getting access to the volume. I like to use the Windows iSCSI Initiator to help me figure out if I can connect or not. Once you've got things working with that one I just ensure the other initiator IQNs are given the same access as the windows one.

You might also be interested in my https://github.com/robinsmidsrod/comstar-soho-helper scripts which makes it easy to create volumes in a typical home setup (where you control the entire network). The scripts should also give you a better understanding of how the different parts of COMSTAR interact with each other. It took me quite some time to figure it all out.

I use Nexenta Core Platform (NCP) 3.0, so it's old and no longer maintained, I believe. NexentaStor is slightly different in the administrative realm, but hopefully close enough. I've been planning to move to OpenIndiana for some time, but I never find time.
I might also be barking up the wrong tree here, maybe your zvol is read-only. I believe some sbdadm or stfmadm command should give you the scsi options for the device (write-back caching, read-only/read-write status etc.). Check the man page.
Thanks for the help! I managed to figure this out today. The issue was with using the emulated "PCnet-FAST III (Am79C973)" card in virtualbox. I switched it over to "Paravirtualized Network (virtio-net)" and all was well. Ipxe is working like a champ.
Great to hear!

Do stick around and help others if you can and know how. Sharing is caring. Smile
Reference URL's