iPXE discussion forum

Full Version: undionly.kpxe and windows7 load problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
First of all thank this fantastic project. I have a problem when undionly.kpxe use to boot windows7 home (linux debian work fine). This screen is locked and the computer reset.
if I use the iso http://boot.ipxe.org/ipxe.iso works perfectly. Start ipxe.krn, dhcp send http://iscsi.informaticaamado.lan/boot.ipxe, load boot.ipxe.cfg, menu.ipxe and boot iscsi.
I've noticed that when I'm using RTL8169 ipxe.krn charge and otherwise undionly driver
What I'm doing wrong?
Thanks and regards.
If everything up to the sanboot command works, but your Windows iSCSI install fails, most likely you've got the gateway issue, or you have in some way done something wrong during installation of your Windows on iSCSI. It could be that you didn't slipstream in a working network driver for your hardware into WinPE. See http://ipxe.org/howto/winpe for details on how to solve that. The gateway issue is covered in the FAQ here: http://forum.ipxe.org/showthread.php?tid=5948

Not sure what your issue is with the realtek/UNDI situation. Need more details.
you're right. It is a gateway problem. I have a network, default gateway and dns for gateway If I configure dhcp to as gateway works perfect.
Is there any way to configure static route on ipxe?

keep default to Internet
route add and as gateway.
Unfortunately no. You'll need to add that static routing in your default gateway, which is most of the time the correct place for it. After all, iPXE doesn't support VPNs or any such thing that usually require static routing either. I'm not entirely sure if iPXE supports static routes in a DHCP response. I don't think so.
I have this setup in my dhcp server. But ipxe not recognized. The configuration works after the computer has booted.

option rfc3442-classless-static-routes code 121 = array of integer 8;
option ms-classless-static-routes code 249 = array of integer 8;

option domain-name-servers;
option routers;

subnet netmask {
option rfc3442-classless-static-routes 24 , 192 , 168 , 3 , 192 , 168 , 1 , 254;
option ms-classless-static-routes 24 , 192 , 168 , 3 , 192 , 168 , 1 , 254;
option domain-search "informaticaamado.lan" , "informaticaamado.cloudns.in";
option domain-name "informaticaamado.lan";

Ok, Best regards.
Thank you very much robinsmidsrod.
Reference URL's