Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Apple Thunderbolt Ethernet LINK DOWN
2017-12-01, 10:22 (This post was last modified: 2017-12-01 10:47 by gzebedin.)
Post: #1
Apple Thunderbolt Ethernet LINK DOWN
Hello @ll,

I'm trying to boot Macbooks via IPXE into a Linux System. I created a NBI which delivers the ipxe.efi to the Macbook. This part works fine.
IPXE also recognizes the Thunderbolt adapter as 14e4-1682 and tells me
[link status: Down (http://ipxe.org/38086193)]
Waiting for link up on net0................. Down (http://ipxe.org/38086193)

The Link never goes up.
On the switch I see the Linkstatus going down and up everytime ipxe tries but there seems to be a problem with the driver.

Has anybody had a similar problem or knows how to fix it. I know for sure there was one version of IPXe maybe 2-3 years ago where this worked. But I never noted the release and after recompiling a new start script via rom-o-matic it stopped working :-(
I also found THIS thread about a similar problem but there was no solution mentioned.

Thank you for helping out!

G.
Find all posts by this user
Quote this message in a reply
2017-12-01, 12:26
Post: #2
RE: Apple Thunderbolt Ethernet LINK DOWN
the 14e4-1682 is BCM57762
I would not be surprised if your issue is more related to what have been seen in http://forum.ipxe.org/showthread.php?tid=8296
So far it seems to be related to the mac firmware.

try to use snponly.efi instead so that the firmware driver is used and see what kind of results that give you
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)