Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue iPXE booting win10 1709 hyper-v vm
2018-03-02, 15:03
Post: #1
Issue iPXE booting win10 1709 hyper-v vm
We are using ipxe via FOG to image machines. It seems after the 1709 update, our (gen 1) hyper-v vms started having issues with ipxe. Attempting to network boot a vm after 1709 (that worked before with no changes) the machine will freeze at "ipxe initializing devices..." and loads up 100% on one core of the cpu. I have left the machine for at least 3 days without it progressing, so I'm pretty sure it has failed at that point. We were using an old version of undionly.kpxe, so I tried the latest master (47849 as of when I built it) and had the same problem.
I tried the intel and ipxe.kpxe files included with fog, which were probably old versions but exhibited the same behavior. Strangely gen 2 vms work without any issues. After much trial and error, I finally compiled an undionly.kpxe that functioned properly in FOG. Commenting out these lines allowed ipxe to continue correctly:
#define DOWNLOAD_PROTO_HTTPS
#define IMAGE_TRUST_CMD
#define CERT_CMD
Unsure why, yet it funtions properly for me now. While I do not need any https or certificate functionality, to me this seems like a bug or issue with compatibility with windows 1709 that you collectively may want to know about. If I have left out any relevant information, let me know and I'll try to respond.
Find all posts by this user
Quote this message in a reply
2018-03-02, 17:52
Post: #2
RE: Issue iPXE booting win10 1709 hyper-v vm
You should probably report this to Microsoft since it seems to be an regression in Gen1 VMs in that Windows 10 version. This was also mentioned on IRC so might get more attention via some other channels as well.

Read the FAQ before posting.
Did you include relevant ipxe.org error urls?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)