Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE support for recent EC2 M5 instances
2018-03-14, 01:51
Post: #1
iPXE support for recent EC2 M5 instances
Hi All,

I'm trying to determine if I'm doing something wrong or if the network adapter in the latest EC2 M5 generation simply isn't supported.

I've build iPXE using the commands in, but I'm using the latest commit (d8c500b7945).

I then import ipxe.usb into EC2 and turn it into an AMI.

When I launch something like a t2.micro with it, it detects the network interface (net0) and can configure it.

When I launch any M5 instance type (or really anything that uses ENA from net0 doesn't show up.

The best example I have is that an m4.10xl will have net0, and m4.16xl will not. Has anyone had any success with the ena driver, and do I maybe need to turn it on/register it when compiling iPXE?

Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)