Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to Run CentOS VM in Oracle Cloud , My VM is Stucked with Error
2018-05-25, 03:02
Post: #1
Trying to Run CentOS VM in Oracle Cloud , My VM is Stucked with Error
Hi ,

I have DHCP enabled on my CentOS image , But VM is stucked on boot with following error . Please help me this .

iPXE 1.0.0+ -- Open Source Network Boot Firmware -- http://ipxe.org
Features: DNS HTTP iSCSI TFTP AoE EFI Menu
IPXE GIT :
IPXE Built for: bin-x86_64-efi/snp.efirom
Configuring (net0 02:00:17:02:02:94)...... ok
NETWORK info :
IP address.....10.0.2.2
Netmask........255.255.255.0
Gateway........10.0.2.1
Domain.........kartikeyvcn.oraclevcn.com
DNS............169.254.169.254
Next Server....169.254.169.254
DHCP...........169.254.169.254
http://169.254.0.4/script.ipxe... ok
Registered SAN device 0x80
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80
Boot from SAN device 0x80 failed: Error 0x7f22208e (http://ipxe.org/7f22208e)
Booting from SAN device 0x80


Thanks
Kartikey
Find all posts by this user
Quote this message in a reply
2018-05-25, 07:07
Post: #2
RE: Trying to Run CentOS VM in Oracle Cloud , My VM is Stucked with Error
My guess is that your SAN disk does not have a structure that is compatible with EFI booting.
It is the firmware of the machine that returns errors to iPXE that it tries to do it's best to inform you about.

Read the FAQ before posting.
Did you include relevant ipxe.org error urls?
Visit this user's website Find all posts by this user
Quote this message in a reply
2018-05-25, 14:53
Post: #3
RE: Trying to Run CentOS VM in Oracle Cloud , My VM is Stucked with Error
You didn't mention what version of CentOS.

CentOS 6.x (and RHEL 6.x) doesn't have the kernel option EFI_STUB compiled in by default.

CentOS 7 (and RHEL 7.x) must have SecureBoot Disabled if SAN Booting.

If you want a diskless CentOS6/CentOS7 machine on EFI, look to NFS Roots. It's generally a bit simpler (although setup can be a pain).

Best,

M^3

"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)