Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HTTPS support on WIMBOOT
2019-03-05, 13:59
Post: #1
HTTPS support on WIMBOOT
Hi

I could boot into WinPE environment with WIMBOOt on HTTP protocol
But it will display "Could not start download:Operation not supported (http://ipxe.org/3c092083)" when I change to HTTS protocol (change wimboot download URL from http to https)
For example :
Original : kernel http://xxxxxx/wimboot
Current : kernel https://xxxxxx/wimboot

I had add the web certificate during iPXE built.
Might I know if it is caused by WIMBOOT is only support HTTP protocol but not HTTPS ?

Thanks.
Find all posts by this user
Quote this message in a reply
2019-03-06, 01:39
Post: #2
RE: HTTPS support on WIMBOOT
This is not related to wimboot in any way (wimboot just loads what is available in memory)

To have https support in iPXE you have to enable DOWNLOAD_PROTO_HTTPS as described at https://ipxe.org/crypto
The error url in the message you got have some other https related information in case you already have HTTPS enabled - and that information fits quite good with you mentioning adding a certificate during build.

Read the FAQ before posting.
Did you include relevant ipxe.org error urls?
Visit this user's website Find all posts by this user
Quote this message in a reply
2019-03-06, 05:00
Post: #3
RE: HTTPS support on WIMBOOT
Hi Nikize

Sorry for the inconvenience and thanks for quick advice
Yes, you are right, it is not related to wimboot since it is used to create virtual filesystem on memory.

It is my fault that I consider I have enabled DOWNLOAD_PROTO_HTTS in general/config.h.
After enable the DOWNLOAD_PROTO_HTTPS, I could successfully chainboot via HTTPS.
Many thanks for your help Smile
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)