Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE boot Ubuntu 18.04 LUN
2019-03-13, 04:45
Post: #1
iPXE boot Ubuntu 18.04 LUN
Hi Guys,

iPXE noob starting out and I’m trying to use iPXE to boot an iSCSI LUN which contains an installed Ubuntu 18.04 LTS O/S, the LUN appears to boot since it shows the Ubuntu Grub menu but then drops out to BusyBox with a few errors as below.

Any idea what I’m doing wrong here?

The steps I took were as follows:

(A) Use KVM (proxmox) to map the empty iSCSI LUN as single disk to a VM (UEFI 64 bit)
(B) Install Ubuntu 18.04 LTS to the empty LUN
© Check Ubuntu is installed to the VM as expected then stop the VM and detach the LUN from the VM.
(D) Boot a different VM (with only a simple 1GB disk attached but set to Network Boot) to iPXE and choose the following menu option:

Code:
:iscsi-boot-ubuntu-18-04-lts
set initiator-iqn [iSCSI-TARGET IQN]
set root-path iscsi:[iSCSI-TARGET-IP-ADDRESS]:::1:${initiator-iqn}
set keep-san 1
echo Booting Ubuntu 18.04.2 LTS (Linux ${arch}) for ${initiator-iqn}
sanboot ${root-path} || goto failed
goto start

(E) iPXE boots the LUN to the Ubuntu "GNU Grub version 2.02" menu and I select “Ubuntu” to start Ubuntu

(F) After a minute or so, the following errors are shown in the terminal and I'm dropped to a BusyBox (initramfs) prompt:

Code:
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group "ubuntu-vg" not found
Cannot process volume group ubuntu-vg
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group "ubuntu-vg" not found
Cannot process volume group ubuntu-vg
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group "ubuntu-vg" not found
Cannot process volume group ubuntu-vg
Gave up waiting for suspend/resume device
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  Volume group "ubuntu-vg" not found
  Cannot process volume group ubuntu-vg
Gave up waiting waiting for root file system device.  Common problems:
- Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT!   /dev/mapper/ubuntu--vg-root does not exist.   Dropping to a shell!


BusyBox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3.1) built-in shell (ash)
Enter 'help' for a list of built-in commads.

(initramfs) _


Thanks!
Find all posts by this user
Quote this message in a reply
2019-03-13, 17:45
Post: #2
RE: iPXE boot Ubuntu 18.04 LUN
iPXE is working.

The problems you are experiencing are mostly with the fact you are working from an installed OS (which thinks it's on local disk). A Kernel booting from iSCSI (or NFS) needs an initrd which has the support enabled for iSCSI (or NFS).

You will need change your /etc/fstab to match your iSCSI LUN(s): note that if you are using LVM/LVM2 on the installed OS, that those mount points will have to be taken into account.

You will also need to rebuild your initrd with iSCSI support.

Personally, I'd setup a clean, blank LUN and install Ubuntu from there instead of trying to switch over a running config.

Another possibility is setting up Ubuntu on NFS (which is easier in some ways).

Best,

M^3

"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
2019-03-14, 01:45
Post: #3
RE: iPXE boot Ubuntu 18.04 LUN
Thanks for the reply @Multimediaman - You’re post makes a lot of sense!

I should have pointed out that it’s Ubuntu Desktop (not server) installed on this LUN since I now think I understand that Desktop doesn’t come with iSCSI support by default so sounds like 2 options:

(A) Remap the LUN to the working VM and boot into Ubuntu Desktop - Install iSCSI support, edit /etc/fstab and rebuild initrd. I should then be able to boot the LUN from a physical host using IPXE.

(B) Start from scratch and install Ubuntu Server to a blank ISCSI LUN (ie by selecting iSCSI install in the installer) - Hopefully then I can just remap this LUN to a physical machine to IPXE boot to it? If I need Ubuntu Desktop, I can then just install the desktop packages on top of the Ubuntu Server install.

I’m assuming there is no way to install Ubuntu Desktop to an iSCSI LUN by doing something clever in IPXE such as mapping the LUN as a local disk?

Thanks again!
Find all posts by this user
Quote this message in a reply
2019-03-14, 16:26
Post: #4
RE: iPXE boot Ubuntu 18.04 LUN
As far as support for installing to iSCSI, yes it is present on all versions of Ubuntu, AFAIK. It usually invoked automatically if the iBFT tables has entries in it (which an installation via NetBoot/iPXE would provide).

"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
2019-03-20, 11:44
Post: #5
RE: iPXE boot Ubuntu 18.04 LUN
Thanks @MultimediaMan,

I managed to boot from iPXE to the Ubuntu LUN by installing it from scratch the the iSCSI LUN using the Ubuntu Server installer!

I have seen another issue since though in that I assumed I could simply clone the LUN (on my Synology NAS) and then add a new iPXE menu to also boot to that new LUN... it connects to the new LUN, loads Ubuntu Grub but then when selecting “Ubuntu”, it then drops the new LUN and boots from the old (Original) LUN?

I’ve raised this issue over at Ubuntu Forums at the following URL but wonder whether this is something to do with iBFT and whether the old (and therefore cloned new LUN) contain some metadata which points to the old LUN target at boot?

https://ubuntuforums.org/showthread.php?...35ea1530a9

Just wondered whether you had come across something similar before?
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)