Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help compiling
2011-06-11, 06:21
Post: #1
Need help compiling
Hi!

I'm having a hard time getting iPXE compiled for my Intel 82576EB (8086:10C9). I have managed to get a gPXE image working
through the "rom-o-matic", but I really want to use iPXE.

Since I'm normaly running on Windows, I downloaded VirtualBox together with a Ubuntu image. I assume I don't have to run the compilation on the same computer that it's meant for, to get the image/ROM?

I start by running this command, after getting the files from git:
Code:
ubuntu@ubuntu-VirtualBox:~/ipxe/src$ make bin/808610C9.rom

The compilation runs for a while, and then stops with the following error:
Code:
[LD] bin/808610C9.rom.tmp
arch/i386/scripts/i386.lds:1: undefined symbol `obj_808610C9' referenced in expression
make: *** [bin/808610C9.rom.tmp] Error 1

Any help is greatly appreciated! Smile
Find all posts by this user
Quote this message in a reply
2011-06-11, 08:53
Post: #2
RE: Need help compiling
Have you verified that you have all the tools for compilation installed on your VM? The list of required tools are here: http://ipxe.org/download

I believe you should be able to install them all on Ubuntu with this command: sudo apt-get install build-essential perl

If this is all good you should verify that the error you're seeing is actually the FIRST error in the compilation chain. To me it seems like an item compiled earlier didn't build correctly for some reason, and that it, as this point, can't be located.

You could also have met a bug, and if so, you might want to try and checkout a slightly older version, possibly one that was before the last time that file (i386.lds) was modified (check the git log, look for the [i386] keyword specifically).

If you find out that an old commit works, doing a git bisect (see http://ipxe.org/howto/bisect) would really help the developers figure out where it broke.
Visit this user's website Find all posts by this user
Quote this message in a reply
2011-06-19, 02:50
Post: #3
RE: Need help compiling
Hi!

I'm again having trouble getting iPXE compiled. I had to destroy the old VM box, so I'm working with the latest clone from git, and it seems there is somethign wrong.

Get this error now:
Code:
ubuntu@ubuntu-VirtualBox:~/ipxe/src$ make bin/808610c9.rom
  [BUILD] bin/main.o
core/main.c:33:1: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘struct’
core/main.c: In function ‘main’:
core/main.c:99:38: error: ‘scriptlet_setting’ undeclared (first use in this function)
core/main.c:99:38: note: each undeclared identifier is reported only once for each function it appears in
make: *** [bin/main.o] Error 1

PS:I got it to compile last time I asked, after installing a few more headers and such, so this is kind of unrelated to the first post.
Find all posts by this user
Quote this message in a reply
2011-06-19, 18:51
Post: #4
RE: Need help compiling
Sorry, I haven't seen that one before. I'd verify that everything in your gcc toolchain is correctly installed, maybe try to do a fresh clone and try again. If it still fails, a bug report to the mailinglist might be your best bet.
Visit this user's website Find all posts by this user
Quote this message in a reply
2011-07-17, 08:43 (This post was last modified: 2011-07-17 08:45 by MultimediaMan.)
Post: #5
RE: Need help compiling
If you can't get it working with Ubuntu, try CentOS 6.0 i386 or Scientific Linux 6.1: during installation, select the Software Development Workstation (last selection), after completing the install go ahead and open a terminal:

Code:
su root
yum update -y

*Reboot after yum update completes.

Open a terminal again,

Code:
su root
yum install syslinux mtools

Then you can install the iPXE stuff:

Code:
git clone git://git.ipxe.org/ipxe.git

then finally

Code:
cd ipxe/src
  make

"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)