Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DHCP] Not issuing
2011-06-15, 17:59
Post: #1
[DHCP] Not issuing
Hi everyone,


I am trying to setup a linux on a DELL Poweredge R610 (Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet (rev 20)):
- The network receive the ipxe binairie (undionly.kpxe)
- then iPXE try to issue another DHCPDISCOVER, at least the console write:
[Image: dhcpfail.jpg]

And I don't see any DHCPDISCOVER on my dhcp server once iPXE is loaded, any idea what could be the problem?

But once I use the iPXE console i am able to do a dhcp net0 after a little while:
[Image: dhcpsuccess.jpg]

Regards,
JM
Find all posts by this user
Quote this message in a reply
2011-06-16, 09:21
Post: #2
RE: [DHCP] Not issuing
Bump Angel
Find all posts by this user
Quote this message in a reply
2011-06-19, 18:48
Post: #3
RE: [DHCP] Not issuing
A wireshark or tcpdump packet trace from your DHCP server's perspective might help debug the issue.
Visit this user's website Find all posts by this user
Quote this message in a reply
2011-06-20, 10:59
Post: #4
RE: [DHCP] Not issuing
(2011-06-19 18:48)robinsmidsrod Wrote:  A wireshark or tcpdump packet trace from your DHCP server's perspective might help debug the issue.

Hi,

Thx for answering, finally I changed the DHCP_MAX_TIMEOUT as followed:
#define DHCP_MAX_TIMEOUT ( 100 * TICKS_PER_SEC )

And now the DHCP request is issued correctly, apparently there a longtime of initialization for these kind of devices. I don't know if you want to change the default value?

Regards,
JM
Find all posts by this user
Quote this message in a reply
2011-06-27, 10:12
Post: #5
RE: [DHCP] Not issuing
(2011-06-20 10:59)mymycracra Wrote:  Thx for answering, finally I changed the DHCP_MAX_TIMEOUT as followed:
#define DHCP_MAX_TIMEOUT ( 100 * TICKS_PER_SEC )

And now the DHCP request is issued correctly, apparently there a longtime of initialization for these kind of devices. I don't know if you want to change the default value?

Is this a spanning tree problem? You may need to enable "portfast" or an equivalent option on the switch port.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)