Post Reply 
 
Thread Rating:
  • 1 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] : iPXE and WDS Config
2016-02-03, 20:53
Post: #21
RE: [SOLVED] : iPXE and WDS Config
Thanks, that is handy to know

sebus
Find all posts by this user
Quote this message in a reply
2016-02-04, 11:26 (This post was last modified: 2017-02-13 14:49 by sebus.)
Post: #22
iPXE and WDS Config
(2013-06-05 10:09)robinsmidsrod Wrote:  Have you tried the SCCM howto? http://ipxe.org/howto/sccm

Just to add that these instructions can be "improved"

There is nice wiki here:
http://www.richud.com/wiki/Windows_7_SCCM_Deploy

But that only gives the TS menu (or one can escape it using Auto-clicker)
But this presents another problem, as the machine downloads and reboots to .wim specified in TS (which negates the initial gain of the fast boot!)

And if all we need to do is a quick clone, then we can use different patching entries: (where WINPE.SP10010C.WIM is boot image to be used with deployed TS)

Code:
echo ** Patching Ramdisk
reg add "HKLM\SYSTEM\CurrentControlSet\Control" /v PEBootType /t REG_SZ /d "Error" /f
reg add "HKLM\SYSTEM\CurrentControlSet\Control" /v SystemStartOptions /t REG_SZ /d " MININT RDIMAGEOFFSET=8192 RDIMAGELENGTH=3161088 RDPATH=NET(0)\\SMSIMAGES\\SP10010C\\WINPE.SP10010C.WIM" /f
reg add "HKLM\SYSTEM\CurrentControlSet\Control" /v FirmwareBootDevice /t REG_SZ /d "ramdisk(0)" /f
reg add "HKLM\SYSTEM\CurrentControlSet\Control" /v PEBootTypeErrorCode /t REG_DWORD /d "2147942413" /f

rem === For UEFI PXE boot the following lines are also needed! ===
reg add "HKLM\SYSTEM\CurrentControlSet\Control\PXE" /v DHCPServerACK /t REG_BINARY /d "" /f
reg add "HKLM\SYSTEM\CurrentControlSet\Control\PXE" /v BootServerReply /t REG_BINARY /d "" /f

This way there is no need for TS engine to do anything else, but just carry on the TS itself)

TsmBootstrap.ini with Unattended=true is required

One can of course argue that there is no PXE Deployment record for machine in SCCM DB, but I rather have this for the speed of initial boot

sebus
Find all posts by this user
Quote this message in a reply
2017-02-10, 22:11 (This post was last modified: 2017-02-10 23:40 by sebus.)
Post: #23
RE: [SOLVED] : iPXE and WDS Config
(2016-01-22 15:14)robinsmidsrod Wrote:  With the current master branch of iPXE (2016-01-21), this has been reported to work properly:

Code:
#!ipxe
set wdsserver:ipv4 192.168.XX.XX
set netX/next-server ${wdsserver}
chain tftp://${wdsserver}/SMSBoot\x64\wdsmgfw.efi

Could not make it work (I have no idea what port is communicates on, as for my testing I needed to disable UDP 4011 on WDS server)

Is that even possible?

http://superuser.com/questions/975512/ue...ain-to-wds
Find all posts by this user
Quote this message in a reply
2017-02-11, 16:27
Post: #24
RE: [SOLVED] : iPXE and WDS Config
(2017-02-10 22:11)sebus Wrote:  
(2016-01-22 15:14)robinsmidsrod Wrote:  With the current master branch of iPXE (2016-01-21), this has been reported to work properly:

Code:
#!ipxe
set wdsserver:ipv4 192.168.XX.XX
set netX/next-server ${wdsserver}
chain tftp://${wdsserver}/SMSBoot\x64\wdsmgfw.efi

Could not make it work (I have no idea what port is communicates on, as for my testing I needed to disable UDP 4011 on WDS server)

Is that even possible?

http://superuser.com/questions/975512/ue...ain-to-wds

You can disable the dhcp referral stuff by setting option 252 properly.
Find all posts by this user
Quote this message in a reply
2017-02-11, 16:39 (This post was last modified: 2017-02-12 21:01 by sebus.)
Post: #25
RE: [SOLVED] : iPXE and WDS Config
I see you mean option 252 as here: http://ipxe.org/appnote/chainload_wds

But what would one expect in that option for the above to work?

With UEFI PXE IPv4->iPXE->menu->.ipxe script

Code:
#!ipxe
cpuid --ext 29 && set arch x86_64 || set arch i386
set proxydhcp/next-server AAA.BBB.CCC.DDD # IP of WDS server
set proxydhcp/filename SMSBoot\x64\wdsmgfw.efi
set proxydhcp/dhcp-server AAA.BBB.CCC.DDD # IP of WDS server ?
set wdsserver:ipv4 192.168.XX.XX
set netX/next-server ${wdsserver}
chain tftp://${wdsserver}/SMSBoot\x64\wdsmgfw.efi

I get WDS to respond but gets "stuck" on only Contacting Server

[Image: contacting_wds.png]

In the smspxe.log I can see a successful PXE boot (as per https://blogs.technet.microsoft.com/ping...-20072012/ )

Code:
Client boot action reply: <ClientIDReply><Identification Unknown="0" ItemKey="16778293" ServerName=""><Machine><ClientID>GUID:841AA243-DB51-4562-AF0D-EB9E4EE64F75</ClientID><NetbiosName/></Machine></Identification><PXEBootAction LastPXEAdvertisementID="" LastPXEAdvertisementTime="" OfferID="SP1201F9" OfferIDTime="02/02/2017 14:40:00" PkgID="SP100115" PackageVersion="" PackagePath="http://sccmserver.domain.local/SMS_DP_SMSPKG$/SP10017B" BootImageID="SP10017B" Mandatory="1"/></ClientIDReply>
    SMSPXE    12/02/2017 19:06:23    7716 (0x1E24)
00:15:5D:A4:A7:99, DEF39572-90C2-F142-B361-C21B8675A333: using advertisement SP1201F9    SMSPXE    12/02/2017 19:06:23    7716 (0x1E24)

but nothing more happens

sebus
Find all posts by this user
Quote this message in a reply
2017-02-13, 15:07
Post: #26
RE: [SOLVED] : iPXE and WDS Config
OK, I seems that I can not block port UDP 4011 on WDS & expect it to work (still not fully clear why, as when pointing to WDS IP from .ipxe script there should be no need for ANY PXE again)

But to make it not reply instantly to PXE requests (as I went with configurable Tiny PXE Server), I just changed

Code:
PXE Response Delay

The following is the registry key that holds the PXE response delay:

HKLM\System\CurrentControlSet\Services\WDSServer\Providers\WDSPXE\Providers\BINLSVC

    Name: ResponseDelay

    Type: REG_DWORD

    Value: <delay time, in seconds>

as per https://technet.microsoft.com/en-us/libr...spx#BKMK_3 to 30 sec

Now TPS replies first & all works as I need it to (but still would prefer to do the lot with only DHCP options!)

sebus
Find all posts by this user
Quote this message in a reply
2017-02-27, 06:44
Post: #27
RE: [SOLVED] : iPXE and WDS Config
(2017-02-13 15:07)sebus Wrote:  OK, I seems that I can not block port UDP 4011 on WDS & expect it to work (still not fully clear why, as when pointing to WDS IP from .ipxe script there should be no need for ANY PXE again)

But to make it not reply instantly to PXE requests (as I went with configurable Tiny PXE Server), I just changed

Code:
PXE Response Delay

The following is the registry key that holds the PXE response delay:

HKLM\System\CurrentControlSet\Services\WDSServer\Providers\WDSPXE\Providers\BINLSVC

    Name: ResponseDelay

    Type: REG_DWORD

    Value: <delay time, in seconds>

as per https://technet.microsoft.com/en-us/libr...spx#BKMK_3 to 30 sec

Now TPS replies first & all works as I need it to (but still would prefer to do the lot with only DHCP options!)

sebus

Hi, sebus:
It's my first time to try ipxe with wds.
I finished most of the work(legacy mode windows,linux), but met the same pro as you , it stuck at :
[Image: contacting_wds.png]
I can't figure it out according to your discribe. Looks like you change something about udp port or regesiter. Can you tell me what exactly you changed ?
Apologize for my bad English, know you can understand what i mean.
Hope you can get me out!Confused
Thanks´╝ü
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)