Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
installing windows7 on iscsi target failed
2013-04-24, 19:52 (This post was last modified: 2013-04-24 19:53 by Aigor.)
Post: #1
Music installing windows7 on iscsi target failed
Hi, i'm tryng to use menu.ipx to install windows7 on iscsi target, o have successfuly setup web server according to menu.ipxe, right in place bootstrap.ipxe,menu.ipxe, undionly.kpxe in /tftpdroot folder, i have successfuly copied whole iso of windows7 adjust configuration, when try to start installation the system askm to prese any key to boot from dvd, after doing so, i get \boot\bcd error.

[Image: test-iscsi-2013-04-24-20-48-42.png]

I'm using synology webserver
Find all posts by this user
Quote this message in a reply
2013-04-24, 22:15
Post: #2
RE: installing windows7 on iscsi target failed
(2013-04-24 19:52)Aigor Wrote:  Hi, i'm tryng to use menu.ipx to install windows7 on iscsi target, o have successfuly setup web server according to menu.ipxe, right in place bootstrap.ipxe,menu.ipxe, undionly.kpxe in /tftpdroot folder, i have successfuly copied whole iso of windows7 adjust configuration, when try to start installation the system askm to prese any key to boot from dvd, after doing so, i get \boot\bcd error.

I'm afraid I have no idea what is in your bootstrap.ipxe or menu.ipxe scripts, so it's hard to give any suggestions about what your problem might be.

I would recommend that you try following the instructions at http://ipxe.org/wimboot to get started with booting Windows over the network. Once you have that working, you can try progressing to iSCSI SAN booting and installation.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2013-04-24, 22:29
Post: #3
RE: installing windows7 on iscsi target failed
(2013-04-24 22:15)mcb30 Wrote:  
(2013-04-24 19:52)Aigor Wrote:  Hi, i'm tryng to use menu.ipx to install windows7 on iscsi target, o have successfuly setup web server according to menu.ipxe, right in place bootstrap.ipxe,menu.ipxe, undionly.kpxe in /tftpdroot folder, i have successfuly copied whole iso of windows7 adjust configuration, when try to start installation the system askm to prese any key to boot from dvd, after doing so, i get \boot\bcd error.

I'm afraid I have no idea what is in your bootstrap.ipxe or menu.ipxe scripts, so it's hard to give any suggestions about what your problem might be.

I would recommend that you try following the instructions at http://ipxe.org/wimboot to get started with booting Windows over the network. Once you have that working, you can try progressing to iSCSI SAN booting and installation.

Michael
Thank you for the answer, it comes from the git hub of forum's owner i just followed the files and adjust with my setup, i' suspect that is a problem of the web server on synology, i'v read something about mod_headers that regulate large file.
Find all posts by this user
Quote this message in a reply
2013-04-25, 09:53
Post: #4
RE: installing windows7 on iscsi target failed
(2013-04-24 22:29)Aigor Wrote:  Thank you for the answer, it comes from the git hub of forum's owner i just followed the files and adjust with my setup, i' suspect that is a problem of the web server on synology, i'v read something about mod_headers that regulate large file.

I would recommend that you try following the instructions at http://ipxe.org/wimboot to get started with booting Windows over the network. Once you have that working, you can try progressing to iSCSI SAN booting and installation.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2013-04-26, 02:40 (This post was last modified: 2013-04-26 07:18 by robinsmidsrod.)
Post: #5
RE: installing windows7 on iscsi target failed
I encountered the same problem, which is the tftp transfer when the default is lowercase, you can view the log will find the problem.now I installed windows7 by
Code:
sanboot --no-describe --keep http://$serverip/windows/win7.iso
Find all posts by this user
Quote this message in a reply
2013-04-26, 08:42
Post: #6
RE: installing windows7 on iscsi target failed
(2013-04-26 02:40)danny Wrote:  I encountered the same problem, which is the tftp transfer when the default is lowercase, you can view the log will find the problem.now I installed windows7 by
Code:
sanboot --no-describe --keep http://$serverip/windows/win7.iso

I will try tonigth at home, the only difference is in --keep in sanboot command line, iso name is all in lowercase
Find all posts by this user
Quote this message in a reply
2013-05-13, 11:33
Post: #7
RE: installing windows7 on iscsi target failed
Did you ever get this to work?

I'm facing the exact same problem, and the --keep option doesn't change anything for me.
Find all posts by this user
Quote this message in a reply
2013-05-24, 08:36
Post: #8
RE: installing windows7 on iscsi target failed
(2013-05-13 11:33)DanielSmedegaardBuus Wrote:  Did you ever get this to work?

I'm facing the exact same problem, and the --keep option doesn't change anything for me.

Proposed reference this method:
“http://ipxe.org/wimboot”。
lah
Find all posts by this user
Quote this message in a reply
2013-05-24, 09:59 (This post was last modified: 2013-05-24 09:59 by DanielSmedegaardBuus.)
Post: #9
RE: installing windows7 on iscsi target failed
(2013-05-24 08:36)danny Wrote:  Did you ever get this to work?

I'm facing the exact same problem, and the --keep option doesn't change anything for me.

No, sorry. I just ended up using an external DVD drive to install from.
Find all posts by this user
Quote this message in a reply
2013-05-24, 15:31
Post: #10
RE: installing windows7 on iscsi target failed
At a guess you were trying to boot from a Windows7 iso served over iSCSI, this will not work.
Find all posts by this user
Quote this message in a reply
2013-05-24, 15:37
Post: #11
RE: installing windows7 on iscsi target failed
(2013-05-24 15:31)ArneLovius Wrote:  At a guess you were trying to boot from a Windows7 iso served over iSCSI, this will not work.

Seems not, but it was part of the robinsmidsrod's githubbed menu stuff that is otherwise so nice, so I guess that's where it went wrong Smile

Care to elaborate on why it doesn't work? I'm pretty clueless to much of this iPXE stuff, so any new knowledge is very welcome Smile
Find all posts by this user
Quote this message in a reply
2013-05-25, 10:19 (This post was last modified: 2013-05-25 10:19 by robinsmidsrod.)
Post: #12
RE: installing windows7 on iscsi target failed
I just want to tell people that some of the examples on how to boot/install Window 7 to iSCSI in my menu script is no longer recommended practice. Use the iPXE WinPE howto to get your windows installer running over the network.

Running the Windows installer from an http-loaded iso DOES NOT WORK!
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)