Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
sanboot and windows 7 iso
2013-04-30, 22:34
Post: #1
sanboot and windows 7 iso
Hi There,

See below my script.
I can boot a winpe.iso image with sanboot : ok.
I can boot a winpe.wim image with wimboot : ok.
I can boot a pmagic.iso image with memdisk : ok.

but I cannot boot a win7.iso with sanboot.
I can actually boot up to the windows wizard where i should a disk to install to but then the wizard complains about a missing cd/dvd driver.
Any idea why?

side note : i have also posted about a all in one pxe server i made to help me boot different scenarios : http://reboot.pro/topic/18488-all-in-one...?p=171734.

Thanks for your help,
Erwan

#!ipxe
set boot-url http://192.168.1.100
######## MAIN MENU ###################
:start
menu Welcome to iPXE's Boot Menu
item
item --gap -- ------------------------- Operating systems ------------------------------
item 7pe_x86_E Boot 7pe_x86 via sanboot OK
item pmagic Boot pmagic via memdisk OK
item wimboot wimboot 7pe_x86_E OK
item win7 Boot win7 installer via sanboot NOK
item bootsan Boot On San OK
item --gap -- ------------------------------ Utilities ---------------------------------
item shell Enter iPXE shell
item reboot Reboot
item
item exit Exit (boot local disk)
choose --default 7pe_x86_E_1 --timeout 30000 target && goto ${target}
########## UTILITY ITEMS ####################
:shell
echo Type exit to get the back to the menu
shell
set menu-timeout 0
goto start

:failed
echo Booting failed, dropping to shell
goto shell

:reboot
reboot

:exit
exit
########## MENU ITEMS #######################
:7pe_x86_E
windows logo
sanboot --no-describe ${boot-url}/images/7pe_x86.iso || goto failed
goto start

:pmagic
initrd ${boot-url}/images/pmagic/pmagic_2013_02_28.iso
chain ${boot-url}/memdisk iso || goto failed
goto start

:win7
#dhcp net0
#set keep-san 1
sanboot --no-describe --keep ${boot-url}/images/win7_x86_sp1.iso || goto failed
goto start

:bootsan
dhcp net0
set keep-san 1
sanboot iscsi:192.168.1.248:tcp:3260:0:iqn.2000-01.com.synology:ds210.name
boot
goto start

:wimboot
kernel wimboot
initrd BOOTMGR BOOTMGR
initrd BOOT/BCD BCD
initrd BOOT/BOOT.SDI BOOT.SDI
initrd SOURCES/BOOT.WIM BOOT.WIM
boot
goto start
Visit this user's website Find all posts by this user
Quote this message in a reply
2013-04-30, 23:11
Post: #2
RE: sanboot and windows 7 iso
(2013-04-30 22:34)erwan.l Wrote:  I can boot a winpe.iso image with sanboot : ok.
I can boot a winpe.wim image with wimboot : ok.
I can boot a pmagic.iso image with memdisk : ok.

but I cannot boot a win7.iso with sanboot.
I can actually boot up to the windows wizard where i should a disk to install to but then the wizard complains about a missing cd/dvd driver.
Any idea why?

Windows has no way to access the SAN-booted .iso image. As soon as the Windows kernel starts up, the real-mode INT 13 interface provided by iPXE's "sanboot" ceases to exist.

For installing Windows over the network, the easiest way is to use wimboot as described at http://ipxe.org/howto/winpe#installing_windows.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2013-05-01, 13:09
Post: #3
RE: sanboot and windows 7 iso
Oki, clear.
As I was able to boot a winpe iso thru sanboot, I thought I would be able to boot the windows installer.

Your tutorial on winpe/wimboot is perfeft : already had fun with it.

Thanks for the answer : great product, great support.

Regards,
Erwan
Visit this user's website Find all posts by this user
Quote this message in a reply
2018-07-02, 14:13
Post: #4
RE: sanboot and windows 7 iso
(2013-05-01 13:09)erwan.l Wrote:  Oki, clear.
As I was able to boot a winpe iso thru sanboot, I thought I would be able to boot the windows installer.

Your tutorial on winpe/wimboot is perfeft : already had fun with it.

Thanks for the answer : great product, great support.

Regards,
Erwan

i have the exact same problem, i have been trying to avoid using winpe as a boot loader because... well... i don't have one.
but , if anyone can send me an iso with an already made one i'll fix that in a jiffy.
Find all posts by this user
Quote this message in a reply
2018-07-16, 05:51
Post: #5
RE: sanboot and windows 7 iso
(2018-07-02 14:13)vascomorais Wrote:  i have the exact same problem, i have been trying to avoid using winpe as a boot loader because... well... i don't have one.
but , if anyone can send me an iso with an already made one i'll fix that in a jiffy.

All windows Vista and later isos have winpe on them, just extract the boot.wim
You won't even have to modify it if you are willing to do manual steps after bootup (Shift+F10 to get CMD prompt and restart the setup from a valid mount point)

Read the FAQ before posting.
Did you include relevant ipxe.org error urls?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 2 Guest(s)