Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 2012 - Boot Fail (System Reboot)
2014-06-09, 04:22
Post: #1
Windows 2012 - Boot Fail (System Reboot)
Hi, guys.

I'm currently trying to provision a server using windows 2012.

I'm using the following script :

#!ipxe

kernel http://$server/gpxelinux/wimboot
initrd http://$server/proxy.php/bootmgr.exe bootmgr.exe
initrd http://$server/proxy.php/bcd bcd
initrd http://$server/proxy.php/boot.sdi boot.sdi
initrd http://$server/proxy.php/segmono_boot.ttf segmono_boot.ttf
initrd http://$server/proxy.php/segoe_slboot.ttf segoe_slboot.ttf
initrd http://$server/proxy.php/wgl4_boot.ttf wgl4_boot.ttf
initrd http://$server/proxy.php/boot.wim boot.wim
boot

However, as soon it loads (100% of boot.wim)
the server just reboot and it doesn't boot the image.

This is working fine with windows 2008 R2, but not with windows 2012 R2, is there anything I might be missing that could cause this ?
Find all posts by this user
Quote this message in a reply
2015-03-09, 11:42
Post: #2
RE: Windows 2012 - Boot Fail (System Reboot)
Most likely you have an additional initrd loaded that is not compatible with wimboot. You should follow the http://ipxe.org/howto/winpe tutorial exactly (it's simpler now) and see if you can get things to work. Also adding a imgstat command before boot command should allow you to figure out possibly what the problem is. Adding the "pause" parameter to the wimboot kernel might also help you out. Make sure you use the latest version of wimboot.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)