Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wimboot 2.1+ from pxelinux
2014-09-03, 05:19
Post: #1
wimboot 2.1+ from pxelinux
I have been using wimboot with pxelinux (6.02) for a few months with great success. Never had an issue with v1.0.6 or more recently v2.0.

However, if I update to 2.1 or 2.2.2, I can no longer boot wim files. The bootloader and wim load fine, but then I get a 'Unrecognized argument error' (see screenshot).

[Image: TuFKGWa.png]

My menu entry looks like this:

Code:
LABEL winpe
    MENU LABEL WinPE
    COM32 linux.c32
    APPEND wimboot initrdfile=winpe/bootmgr.exe,winpe/bcd,winpe/boot.sdi,winpe/boot.wim

If I downgrade to wimboot v2.0, I can immediately boot to WinPE again.

Did the required arguments or order of them recently change, or I am doing something wrong?

Thanks.
Find all posts by this user
Quote this message in a reply
2014-09-05, 10:53
Post: #2
RE: wimboot 2.1+ from pxelinux
The newer version of wimboot supports cmdline arguments, and the way you're calling it from pxelinux ends up pushing the cmdline that is supposed to go to linux.c32 into wimboot. BOOT_IMAGE and initrdfile are not valid parameters to wimboot. See http://ipxe.org/wimboot for details on the supported cmdline params.
Visit this user's website Find all posts by this user
Quote this message in a reply
2014-09-09, 05:24
Post: #3
RE: wimboot 2.1+ from pxelinux
I also have a vested interest in this, and I don't think the original question was really answered. There doesn't appear to be anything on the wimboot doc page mentioned that's relevant to pxelinux, everything is ipxe, which is understandable because this is the ipxe website afterall. However, the question still remains, will wimboot2.1+ work with pxelinux? I'm sorry if I'm asking a dumb question but there's also a very good chance that I don't know what i'm looking for.

But if pxelinux support was actually removed, with all due respect, I find that to be a very unwise decision. I really like ipxe but unfortunately, I tend to work with very new devices and very few are supported by ipxe, which makes it impossible for me to use ipxe atm.
Find all posts by this user
Quote this message in a reply
2014-10-21, 20:58
Post: #4
RE: wimboot 2.1+ from pxelinux
Hello,

I am also interested in a solution.
With Version 2.0.0 I can boot my Windows PE. With the new version 2.3.0 I get the same error message like BitBub.
I use ipxe and chainloading pxelinux 5.02.

Thanks
Find all posts by this user
Quote this message in a reply
2014-11-13, 16:52
Post: #5
RE: wimboot 2.1+ from pxelinux
Has anyone find a solution to this yet? I am getting the same issue where the arguments are getting passed to WIMBOOT.

I am using WIMBOOT v2.4.0 and PXELINUX v6.03

Any help would be appreciated, Thanks.
Find all posts by this user
Quote this message in a reply
2014-12-03, 16:32
Post: #6
RE: wimboot 2.1+ from pxelinux
If it wasn't clear, if you want to load wimboot from pxelinux, you need to make sure BOOT_IMAGE and initrdfile are NOT specified as kernel command-line parameters. Linux kernels generally ignore parameters they don't understand, but wimboot is apparently picky and fails to start if it sees unsupported parameters. Getting rid of the parameters should fix your problem.
Visit this user's website Find all posts by this user
Quote this message in a reply
2014-12-09, 14:04
Post: #7
RE: wimboot 2.1+ from pxelinux
(2014-11-13 16:52)Yuru Wrote:  Has anyone find a solution to this yet? I am getting the same issue where the arguments are getting passed to WIMBOOT.

I am using WIMBOOT v2.4.0 and PXELINUX v6.03

Any help would be appreciated, Thanks.

wimboot v2.4.1 should fix this problem.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)