Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iscsi handoff problem
2016-01-09, 11:26
Post: #1
iscsi handoff problem
Hello everyone,

I have a system that boots via iscsi just fine, but I need to point it to another target and port. The volume itself isnt changing, just the target name and port.

The target iqn and IP port number are changed in the ipxe config and from what I can tell, the system boots as expected... then when ipxe hands the iscsi session off to the OS, it loses the connection and the OS crashes.

My guess is that the handoff isn't passing the new port number and iqn.

I'm using fedora 23. I can't see where the OS stores the iscsi configuration. All those files are empty... probably because it inherits it from ipxe.

If I look at an strace of "iscsiadm -m session -P 3", I can see that it's pulling it's iscsi values from /sys/class/... -- unfortunately, that structure is dynamically built when the system boots so I can't edit the files there.

So, how can I get the port number change to pass through? I'm moving from port 3160 to 44301.

Any help would be appreciated.

Thanks to you all in advance.
-Michael
Find all posts by this user
Quote this message in a reply
2016-01-15, 08:27 (This post was last modified: 2016-01-15 08:27 by mcb30.)
Post: #2
RE: iscsi handoff problem
(2016-01-09 11:26)msmcknight Wrote:  I have a system that boots via iscsi just fine, but I need to point it to another target and port. The volume itself isnt changing, just the target name and port.

The target iqn and IP port number are changed in the ipxe config and from what I can tell, the system boots as expected... then when ipxe hands the iscsi session off to the OS, it loses the connection and the OS crashes.

My guess is that the handoff isn't passing the new port number and iqn.

I'm using fedora 23. I can't see where the OS stores the iscsi configuration. All those files are empty... probably because it inherits it from ipxe.

Fedora has the option to either use hardcoded iSCSI target information (recorded at the time that you performed the installation), or to pick up the iSCSI target information dynamically from the iBFT created by iPXE. I don't know the precise configuration change you need, but searching for "Fedora iSCSI iBFT" should get you some answers.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-01-18, 22:07
Post: #3
RE: iscsi handoff problem
Thanks for the reply.

I looked for instructions on changing the iBFT, but everything I see seems to indicate that it has to be changed in the firmware... which in this case would be iPXE, I think.

If anyone knows a specific command syntax or file that can be edited, that would be helpful. I'm very new at PXE in general, and fairly new at Fedora.
Find all posts by this user
Quote this message in a reply
2016-01-18, 22:57
Post: #4
RE: iscsi handoff problem
(2016-01-18 22:07)msmcknight Wrote:  I looked for instructions on changing the iBFT, but everything I see seems to indicate that it has to be changed in the firmware... which in this case would be iPXE, I think.

The iBFT is generated automatically by iPXE whenever you use iPXE to perform an iSCSI boot. However, your Fedora initrd is not using the contents of the iBFT; it is instead using values hardcoded into the initrd itself.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-01-19, 08:16
Post: #5
RE: iscsi handoff problem
To fix your initrd.img issue, boot into rescue mode and mount the iSCSI target manually, chroot into /boot (or use another Fedora system to mount it - you need kernel-devel, iscsiadm to update the initrd.img file), then recompile the initrd.img using Dracut and the correct Dracut arguments for the renamed LUN... that should get you back in business.

"Thus far, you have been adrift within the sheltered harbor of my patience..."
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)