Post Reply 
 
Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blank Screen ESX5.1 VMWare V9
2016-01-14, 18:23 (This post was last modified: 2016-01-14 18:24 by khanand.)
Post: #1
Blank Screen ESX5.1 VMWare V9
Hi,

We've stumbled across a bit of a strange problem resulting in blank screen when building Windows 2012 server during the WINPE stage of the build process.

Components involved are iPXE, WIMBoot 5.1, ESX 5.1, Virtual Machine hardware version 9, WINPE 5.1, Windows 2K8 WDS, Windows Server 2012.

The problem seems to occur when WIMBoot calls winload.exe from WINPE 5.1 - the display goes blank but the build continues as normal, just can't be seen! using Virtual Hardware Version 8 works with no issues, it's only when we select VM version 9 in vCenter as the virtual machine does it become a problem. It smacks of VMware driver issues in WINPE, but the latest drivers have been injected into the PE WIM.

Anyone seem anything similar? any help appreciated Smile
Find all posts by this user
Quote this message in a reply
2016-01-14, 18:37
Post: #2
RE: Blank Screen ESX5.1 VMWare V9
(2016-01-14 18:23)khanand Wrote:  The problem seems to occur when WIMBoot calls winload.exe from WINPE 5.1 - the display goes blank but the build continues as normal, just can't be seen!

Do you send any options to wimboot, if not try adding the "gui" option and if you do have "gui" on the wimboot prompt, try removing it.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-01-14, 22:13
Post: #3
RE: Blank Screen ESX5.1 VMWare V9
(2016-01-14 18:37)NiKiZe Wrote:  Do you send any options to wimboot, if not try adding the "gui" option and if you do have "gui" on the wimboot prompt, try removing it.

Exactly what I was going to suggest!

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-01-19, 17:09 (This post was last modified: 2016-01-19 17:16 by khanand.)
Post: #4
RE: Blank Screen ESX5.1 VMWare V9
Hey ...

Thanks for the suggestion, using the 'gui' switch helps reveal what's behind the blank screen. A BSOD with the error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. The BSOD only occurs if we select SERVER 2012 as the guest operating system on the virtual machines properties. If the OS is set to 2K8 no issue which I find a little strange as my understanding is ... setting the guest OS shouldn't make any difference in terms of the way the VM is presented to the operating system.

We tested ESX 5.5 and VM HW 10 - seems that whatever we set the guest OS to in this release we get a BSOD ...
Find all posts by this user
Quote this message in a reply
2016-01-19, 17:16
Post: #5
RE: Blank Screen ESX5.1 VMWare V9
(2016-01-19 17:09)khanand Wrote:  Thanks for the suggestion, using the 'gui' switch helps reveal what's behind the blank screen. A BSOD with the error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. The BSOD only occurs if we select SERVER 2012 as the guest operating system on the virtual machines properties. If the OS is set to 2K8 no issue which I find a little strange as my understanding is that setting the guest OS shouldn't make any difference in terms of the way the VM is presented to the operating system.

It potentially affects which virtual hardware is presented to the guest. It would be very reasonable for VMware to decide to present a known-good list of virtual hardware, and that list is likely to vary by OS.

Michael
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-01-19, 17:43
Post: #6
RE: Blank Screen ESX5.1 VMWare V9
(2016-01-19 17:16)mcb30 Wrote:  
(2016-01-19 17:09)khanand Wrote:  Thanks for the suggestion, using the 'gui' switch helps reveal what's behind the blank screen. A BSOD with the error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. The BSOD only occurs if we select SERVER 2012 as the guest operating system on the virtual machines properties. If the OS is set to 2K8 no issue which I find a little strange as my understanding is that setting the guest OS shouldn't make any difference in terms of the way the VM is presented to the operating system.

It potentially affects which virtual hardware is presented to the guest. It would be very reasonable for VMware to decide to present a known-good list of virtual hardware, and that list is likely to vary by OS.

Michael

you mean known good as in compatible with which components? I don't see the issue using native WDS (wdsnbp.exe) so the problem is IPXE or WIMBOOT it seems ?
Find all posts by this user
Quote this message in a reply
2016-02-25, 08:41
Post: #7
RE: Blank Screen ESX5.1 VMWare V9
This is the same exceotion as we have talked about on IRC Michael. So might be something that we can try to address as well with the Dell HW.
Find all posts by this user
Quote this message in a reply
2016-08-23, 08:01
Post: #8
RE: Blank Screen ESX5.1 VMWare V9
Try to config your VM to only have 1 vCPU. This has worked for me.

Have a look at: http://forum.ipxe.org/showthread.php?tid=8115
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)