Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ipxe boot thinstation ?
2016-06-29, 11:02
Post: #1
ipxe boot thinstation ?
when use script
kernel ${base-url}/boot/vmlinuz
initrd ${base-url}/boot/initrd
imgargs vmlinuz splash=silent,theme:default load_ramdisk=1 ramdisk_blocksize=4096 root=/dev/ram0 ramdisk_size=786432 console=tty1 vt.global_cursor_default=0 quiet loglevel=3 LM=3
boot || goto failed

Get error

kernel panic - not syncing :VFS: Unable to mount root fs on unknown-block(1,0)
kernel Offset: disabled
---[ end Kernel panic - not syncing: VFS: Unable to mout root fs on unknown-block(1,0)

what's wrong?
Find all posts by this user
Quote this message in a reply
2016-07-07, 22:59
Post: #2
RE: ipxe boot thinstation ?
(2016-06-29 11:02)zulinfi Wrote:  when use script
kernel ${base-url}/boot/vmlinuz
initrd ${base-url}/boot/initrd
imgargs vmlinuz splash=silent,theme:default load_ramdisk=1 ramdisk_blocksize=4096 root=/dev/ram0 ramdisk_size=786432 console=tty1 vt.global_cursor_default=0 quiet loglevel=3 LM=3
boot || goto failed

Get error

kernel panic - not syncing :VFS: Unable to mount root fs on unknown-block(1,0)
kernel Offset: disabled
---[ end Kernel panic - not syncing: VFS: Unable to mout root fs on unknown-block(1,0)

what's wrong?

Hello zulinfi,

I was getting an error similar to yours earlier today.
I am booting Clonezilla Live over Ethernet.

Here is the script I use: https://github.com/jbirlingmair/my-ipxe-...menu2.ipxe
Code:
:clonezilla

kernel tftp://${tftp}/Clonezilla/vmlinuz
initrd tftp://${tftp}/Clonezilla/initrd.img
imgargs vmlinuz boot=live live-config noswap edd=on nomodeset ocs_live_run"ocs-live-general" locales=en_US.UTF-8 vga=788 keyboard-layouts=en nosplash fetch tftp://${tftp}/Clonezilla/filesystem.squashfs
boot || goto failed

The issue I was having was I needed to make sure to take the --keep off of the menu background.

Try this
Code:
kernel ${base-url}/boot/vmlinuz
initrd ${base-url}/boot/initrd
imgargs vmlinuz splash=silent,theme:default load_ramdisk=1 ramdisk_blocksize=4096 root=/dev/ram0 ramdisk_size=786432 console=tty1 vt.global_cursor_default=0 quiet loglevel=3 LM=3
imgstat
read void
boot || goto failed
That will allow you to see what images are loaded and which one is selected. If there is a PNG in there then you had the same problem as me.
The png was confusing the kernel.

That may be your problem if you are using the console command.
Find all posts by this user
Quote this message in a reply
2016-07-20, 20:25
Post: #3
RE: ipxe boot thinstation ?
I have this configuration in *.ipxe file:

#!ipxe

dhcp
kernel http://IPADDRESS/ThinStation/vmlinuz initrd=initrd initrd=thinstation.conf.buildtime splash=off console=ttyS3 load_ramdisk=1 ramdisk_blocksize=4096 root=/dev/ram0 ramdisk_size=786432 vt.global_cursor_default=0
initrd --name initrd http://IPADDRESS/ThinStation/initrd
boot

Booting only to text terminal. Not start graphical user inteface.
Find all posts by this user
Quote this message in a reply
2016-08-02, 18:53
Post: #4
RE: ipxe boot thinstation ?
Are you booting in Legacy or EFI mode? I see you have added initrd=initrd in the last response which is needed in EFI mode. But it is also common to have an old kernel with bugs in regards to initrd when using efi.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)