iPXE discussion forum

Full Version: Apple Thunderbolt Ethernet LINK DOWN
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello @ll,

I'm trying to boot Macbooks via IPXE into a Linux System. I created a NBI which delivers the ipxe.efi to the Macbook. This part works fine.
IPXE also recognizes the Thunderbolt adapter as 14e4-1682 and tells me
[link status: Down (http://ipxe.org/38086193)]
Waiting for link up on net0................. Down (http://ipxe.org/38086193)

The Link never goes up.
On the switch I see the Linkstatus going down and up everytime ipxe tries but there seems to be a problem with the driver.

Has anybody had a similar problem or knows how to fix it. I know for sure there was one version of IPXe maybe 2-3 years ago where this worked. But I never noted the release and after recompiling a new start script via rom-o-matic it stopped working :-(
I also found THIS thread about a similar problem but there was no solution mentioned.

Thank you for helping out!

the 14e4-1682 is BCM57762
I would not be surprised if your issue is more related to what have been seen in http://forum.ipxe.org/showthread.php?tid=8296
So far it seems to be related to the mac firmware.

try to use snponly.efi instead so that the firmware driver is used and see what kind of results that give you

I'm running into the same issues with the adapter here.

Tried the snponly.efi as well. Doesn't help unfortunately. Output is:

iPXE initialising devices...ok

iPXE 1.0.0+ (546dd) -- Open Source Network Boot Firmware -- http://ipxe.org

net0: a8:20:66:3e:12:45 using NII on NII-0000:0a:00.0 (open)
[Link:up, TX:0 TXE:0 RX:0 RXE:0]
Configured (net0 a8:20:66:3e:12:45).................. No configuration methods succeeded (http://ipxe.org/040ee186)
No more network devices

Loops 3 times, then reboots.

Any ideas?
Which confirms that it is the Apple Firmware that is most likely broken in regards to the NII implementation...

try building ipxe (snponly.efi) with DEBUG=nii,snp,snponly and see what you get...
also enter shell and do:

we expect dhcp to fail as before, but the output of second ifstat compared to the first ifstat might be interesting.

didn't see much in the debug output. Did run the commands

iPXE> ifstat
net0: a8:20:66:3e:12:45 using NII on NII-0000:0a:00.0 (closed)
[Link:up, TX:0 TXE:0 RX:0 RXE:0]
iPXE> dhcp
Configuring (net0 a8:20:66:3e:12:45)............. No configuration methods succeeded (http://ipxe.org/040ee186)
iPXE> ifstat
net0: a8:20:66:3e:12:45 using NII on NII-0000:0a:00.0 (closed)
[Link:up, TX:0 TXE:19 RX:0 RXE:0]
[TXE: 9 x "Error 0x2a086089 (http://ipxe.org/2a086089)"]
[TXE: 1 x "Operation canceled (http://ipxe.org/0b6a4095)"]
[TXE: 9 x "Operation canceled (http://ipxe.org/0b086095)"]
Reference URL's