iPXE discussion forum

Full Version: Using iPXE to chain load Windows PE shows blank screen in Dell notebook
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have both PC and Dell notebook in my LAN environment. Both PC and Dell notebook supports PXE boot.

I attempt to chain boot into Windows PE with SanBoot iscsi target:

2. undionly.kpxe
3. Press Ctrl-B to iPXE command line
4. set keep-san 1
5. set skip-san-boot 1
6. sanboot iscsi-target
7. chain tftp://

Boot PC using above steps does boot into Windows PE environment with iscsi target available for Windows setup.

However, Dell notebook using same steps boot the Windows PE too, but it doesn't show the GUI screen as what PC does. I have tried 2 dell notebook and both giving same result. My Windows PE image will show a cmd windows after loading the Windows PE. The dell notebook doesn't show anything and screen just blank. I try to type exit and press enter, the notebook will reboot. I feel it did boot into Windows PE but doesn't show the GUI screen.

I then try another steps using PXE Linux:

2. pxelinux.0
3. show menu "pxelinux.cfg/default"
4. kernel windows.pe/pxeboot.0

Both PC and Dell notebooks boot into Windows PE GUI environment and I can see the GUI screen for notebook as well.

Both scenarios using same WinPE image.

What could cause the notebook using iPXE to chain load WinPE shows blank after booting?

Thank you.
I think the relative paths are different: iPXE and PXELINUX.0 behave nearly opposite when it comes to relative paths.

Refer to this link: http://www.ipxe.org/cmd/chain

pxelinux.0 always looks to the URI of the root of the TFTP directory (all paths are relative to tftp://

iPXE (undionly.kpxe) when chainloading the paths are relative to the chainloaded path. (tftp://

The problem is when you are chainloading, the pxeboot.0 is passed the absolute path of tftp:// instead of "falling back" to tftp://

I think if you copy the PE Sub-Directories into the tftp:// directory it will work.
Reference URL's