iPXE discussion forum

Full Version: Any network commands don’t work.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I’m so frustrated, because I can’t make any network commands work, like DHCP, so the my script just freezes every time. At school, it works just fine! I’m using HP Pavilion x360, with 64-bit processor; it’s Intel i3.
Here’s what it looks like at home, in iPXE shell, when I issue the DHCP command:

iPXE> dhcp
iPXE> ifstat
iPXE> _

No response, just another prompt. And like I said, if I put it in a script, it freezes.

Does anyone know, why or have a similar experience?
First of, if ifstat does not show any devices, that indicates that there is no nics detected by iPXE at all.
are you sure you don't get any messages when running dhcp?

Are you sure your script actually freezes? my guess is that it instead exits due to some kind of error.

What build of iPXE are you running? (as in what is the filename of the file that you are using if you built it from the iPXE sources)
That information tells us which platform it is running under, as well as which drivers are included in the build.

When we have this we can start to identify why no NIC is detected, and for this it is also a good idea to provide the PCI ID of the device.
Best way to collect this is to run lspci -nn under linux, and copy the relevant line that contains your Ethernet device.
I’m running iPXE.iso, an ISO file.

The lspci -nn shows 19 lines. The last two are:
Network controller [0280]: Intel Corporation Wireless 3165 [8086:3165] (rev 81)
Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev 01)

Not sure if the second one isn’t just an SD card reader, but I included it.
Your wifi card, not supported in iPXE at this time: Intel Corporation Wireless 3165 [8086:3165]
Card reader, not relevant: RTS522A PCI Express Card Reader [10ec:522a]

Is there no wired network card in the machine?
You should have an Ethernet controller
Or is this a machine where the NIC is connected via USB, if so check for it with lsusb, it will need different builds of iPXE to work.
Under lspci -nn, there's nothing else that could be interpreted as Ethernet controller.
Under lsusb, I've got: Device 1 - Linux Foundation 3.0 root hub
Device 2 - Sunplus Innovation Technology Inc.
Device 3 - Intel Corp.
Device 4 - SanDisk Corp. Ultra (I run Linux from a USB key)
Device 1 - Linux Foundation 2.0 root hub
In Windows, under system info, before that Wireless-AC 3165, the only thing I have is: Microsoft Kernel Debug Network Adapter, PNP Device ID: ROOT\KDNIC\0000; it's driver is kdnic.sys. Does that amount to anything?
Do you have a wired NIC in the machine? and does that work in windows or any other OS?
Or is the machine WiFi only?
I don’t have a RJ-45 jack, but when I use my USB3-Ethernet adapter, I am capable of wired internet connection. But it doesn’t look like have a dedicated card/NIC. Is it possible, that it’s just software? Maybe, and kdnic.sys is managing it...
I need to solve this, somehow. Do you think I could buy an external Ethernet card?
thank you for confirming that you only have a usb nic.
You will need to have it connected for it to show up in device manager or with lsusb when running linux.

Once we know which nic you have we can help you build a version of iPXE that hopefully work with your USB nic.

The information about USB nic is vital and would have been good to include in your opening post.
OK, I have a connected right now. The only new line, after using the command lsusb, is first line, that now reads: Bus 002 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Nothing else new.
I think that NIC supports standard USB network protocols

try building bin/ncm--ecm.usb
This will only have support for generic usb nic devices.
Thank you, I will try that this afternoon. Sorry—was that ncm or ecm? When I do, how do I then burn it onto the USB? From my previous experience, I was only able to successfully burn ISO images onto USBs…
it's not ncm or ecm, it is ncm--ecm
use dd to copy the image to the flash drive
burning usbs is bad, not only do you destroy the device, it also generates smoke that's not good for you, so try to not burn usb flash drives please Wink
Hello again. I tried to build the ncm--ecm.usb, but I get stopped right before the end:
/bin/sh: 1: .util/zbin: Permission denied
Makefile.housekeeping:1266: recipe for target ‘bin/ncm--ecm.hd.zbin’ failed

Any ideas?
PS: I promise I won’t burn USBs anymore... It’s barbaric. 😔
OK, I’m one step further. I have the ncm--ecm.usb file, but I’m not sure how to “put” it on my usb stick, so that it boots.
Reference URL's