iPXE discussion forum

Full Version: ipxe chainload fail with "Nothing to boot" in ipv6
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

trying to boot the latest ipxe.efi on Intel i350 NIC card in ipv6 mode.

this works fine for DHCPv4, but for DHCPv6 + ipv6 I am not able to get chainload working. It always fails in the end with error

Nothing to boot: no such file or directory (http://ipxe.org/2d03e18e)

I think i might have got lucky and it worked couple of times, but 99% of time it never goes through. Ipxe does see the net0 and net1 devices which are the i350 card, and there are 4 other ports for X710 cards also.

ANyone can shed some light how I might proceed to troubleshoot this? How can I force ipxe.efi to go to the shell?
press Ctrl-B to go to shell when it prompts you, or if your firmware has alternative ideas of what keypresses are, then use ESC, B instead.
Or if you really want, build iPXE with an embedded script with just shell.

I would recommend you to do what it says in that error url: "Nothing to boot: no such file or directory (http://ipxe.org/2d03e18e)"
Please come back here with the information you collect from those steps.

Thanks for your prompt reply. I tried the commands listed in the url and got:


....No UDP connection listening on port 67
.UDP closed

and the ${filename} and ${root-path} variables were empty

I have undefined ipv4 in general.h as

#undef NET_PROTO_IPV4 /* IPv4 protocol */
#define NET_PROTO_IPV6 /* IPv6 protocol */

So why is it going to port 67? Is it confused about DHCP4 vs DHCP6?

Reference URL's