iPXE discussion forum

Full Version: Cannot boot due to Error 0x040ee119.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, everyone.
I faced Error 0x040ee119 while booting my cluster with InfiniBand.
Only two of the clusters work normally, and the rest cause the following error:

FlexBoot v3.4.752 (PCI 02:00.0) starting execution...ok
FlexBoot initialising devices...
Initialising completed.

FlexBoot v3.4.752

net0: GUID __:__:__:__:__:__:__ - MAC __:__:__:__:__:__
Using ConnectX-3 on PCI02:00.0 (open)
  [LINK:down, TX:0 TXE:0 RX:0 RXE:0]
Waiting for link-up on net0........ ok
Configuring (net0 __:__:__:__:__:__).....................
................ Error 0x040ee119 (http://ipxe.org/040ee119)
No more ports. Exiting FlexBoot...
... (Loop) ...

I am using a SwitchX®-2 based FDR InfiniBand and CentOS 7.
Please give me a solution or advice.
Press ctrl-b during boot to get into the shell
run dhcp and see if that works.
if not, try to run dhcp again.
Still not working, start to make packet captures to see what is going wrong, and find which end it is that isn't responding.

I'm sure that there is more to that error message that you have left out.
Not to mention everything that is already written on that error page, really make sure to read the full page http://ipxe.org/040ee119
Thanks for your reply.
I pressed ctrl+b after an error, but I cannot get into the shell.
Ctrl+b is only working to configure Flexboot. (i.e. invoking the user interface)
No other solution was found in the UI.

Is there something I'm missing?
press ctrl-b before error (if this was in efi mode and buggy firmware implementation use esc, b instead, but this is pcbios so not relevant)
As you said, I ran dhcp from the shell.
The following output is output.
But I can not understand "Not enough space".

FlexBoot> dhcp
ConnectX3 0x31ae4 command 0x11 failed with status 01:
ConnectX3 0x31ae4 could not write MTT at 200
Could not open net0: Not enough space (http://ipxe.org/31136006)
FlexBoot> dhcp
... (Loop) ...
I would try to get support from FlexBoot - but essentially it fails to allocate memory for some structure or other
I solved this problem.
The boot section of my servers has been crashed.
So, I just formatted my servers, simply.
I don't know why the servers have been crashed, but I expected the problem has caused by over-power supply.

Thanks for your help.
Reference URL's