iPXE discussion forum

Full Version: IPXE :: Windows 10 iSCSI disk installation, second stage fails (error 0xc0000428)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

VM (Legacy/BIOS mode) in VMware Workstation 14 boots through iPXE and proceeds to Windows 10 installation. First stage goes well and copies files on iSCSI disk.

After reboot when second stage starts (sanattach replaced with sanboot) I get following error message.

Is there the solution for this error?

Thank you,

--- Error Message -----------------------------

Your PC/Device needs to be repaired

The operating system couldn't be loaded because digital signature of a file couldn't be verified

Error code: 0xc0000428

You'll need to use recovery tools. If you don't have any installation media (like a disk or USB device), contact your PC administrator or PC/Device manufacturer.
So the part that actually gives us information is "digital signature of a file couldn't be verified" there probably is an UPPER_CASE_ERROR as well?
How did you install the nic drivers?
have you worked thru all already existing threads about iSCSI with windows 10 that are on the forum?

To even have a chance of getting this to work, I would use clean Microsoft ISO provided winpe, without mods, also use the drivers that comes with windows, without adding your own, since that does give these kind of issues a lot it seems. But then again, you probably will get other BSoDs instead as discussed in other threads.
Hi NiKiZe,

well, winpe was prepared with adding iSCSI optional packages according Microsoft website, iscsicpl.exe and required library files was copied manually before image was 'dismounted'. My procedure of integrating packages is based on the following article with some improvements [achitecture, for loops, debugging].

Installation media for Windows 10 Enterprise was downloaded from internet and not from Microsoft itself as I could not find direct link on 'Enterprise' version.

ISO: en_windows_10_enterprise_2016_ltsb_x64_dvd_9049483.iso
MD5: e39ea2af41b3710682fe3bbdac35ec9a
SHA256: 3874bc7160ed10f28744dc2b00f9518af99e706296b969fb7eaf26009e1caf76

Right now I try to install from stock ISO image (Windows 10 Pro) downloaded from Microsoft website, ISO image mounted in Linux and shared with Samba over network.

ISO: Win10_1903_V1_English_x64.iso
MD5: 8ba0e81b276d9052e8538deb0cf6c7d0
SHA256: 9846dfbdd7c39eb8d025e0f28e180c6f4084ecf87ecd11805cd19c205f7a3b4e

Network driver (e1000e) at first stage is coming from winpe image and for second stage should come from ISO image.

The image with 'Enterprise' in image name might been altered in some way although I do not think that NIC drivers (or other drivers) was added to it.

Is there any Microsoft website where I could get MD5, SHA256 sums to compare if ISO images are 'prestine'? Microsoft provides a list of releases withougt control sums.

I did some reading on internet about 0xc0000428 error and it looks like people had this problem UEFI secure boot process which is not applicable in my case as I boot virtual machine in Legacy BIOS mode.

I will skim through the forum on Windows 10 installation, a quick search for error code 0xc0000428 came 'empty' and I decided to add new post.


installation from stock ISO image downloaded from Microsoft website failed after first reboot with following message bellow

This time installation is complaining about NDIS driver and particularly it refers to IRQL.

Ok, time to check forum if somebody already stumble on this issue.


---- Message -------------------------------------------
Your PC ran into a problem and needs to restart. We'll restart for you.

For more information about this issue and possible fixes, visit https://www.windows.com/stopcode

If you call a support person, give them this info:
What failed dump NDIS.SYS

Orakel von Delphi

(2019-09-13 18:04)Andromeda_x Wrote: [ -> ]Ok, time to check forum if somebody already stumble on this issue.


Hey Andromeda_x - i had the same problem and have a solution Smile

Its a Bug in Windows 10 - it is no more possible to use pagefile.sys on iSCSI Disks! I found out this after many many days troubleshooting on this problem. With Windows 10 Version 1809 it still works. But erlier versions and newer versions do NOT work.

To successfull install to iSCSI just remove pagefile.sys after first step.

When u install from booted winpe, call setup.exe with /noreboot. Then start regedit and load hive HKEY_LOCAL_MACHINE from youre fresh installed system (typically D:\windows\system32\config\system). Then go to @loaded hive: \SYSTEM\ControlSet001\Control\Session Manager\Memory Management -> inside this u will find "PagingFiles" - just delete the string inside so this is completly empty. With this u disable paging to the C:\pagefiles.sys. After this unload hive, reboot and enjoy!

Do not activate pagefile.sys again on the iSCSI disk after installation - it will result in BSOD with the same error as before. But u can try without risk, Systems will crash and comes up again without pagefile.sys.

It is not possible to update this installation! When u try to update maybe 1809 to 1903 or 1909 the system will not come up after first stage. As a workaround for this problem is simply boot this into a virtual machine (as local Disk - raw mapping whole disk), do the update - after update i can use it as before with iSCSI boot.

Another hint: u have to use a EN-US Version for installing with winpe (wimload). All other languages u will get an driver error at the end of the first step (before the reboot).

Hope i can help u with this.

Orakel von Delphi
Reference URL's