iPXE discussion forum

Full Version: iPXE install of KVM VPS leaves VNC hung
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
On several KVM VPSes from various vendors, I hit ^B in the VNC console on
SolusVM and install an image from openboot.xyz. Recently I bought a new VPS
and found that after Ctrl-Alt-Reset, the VNC console doesn't pause for ^B but
plows ahead trying to boot from disk and CD-ROM. The vendor tells me they
don't support custom ISOs.

After some digging around, I ran across this script:


This worked great for me. I substituted the openboot.xyz kernel (.lkrn) file, and
was able to install whatever I wanted. Everything works normally, SSH access,
rebooting, etc.

After rebooting, I tried to use the VNC console, and it is frozen with one line
on the screen:

/dev/vda1: clean, 65503/2621449 files, 1224852/10485248 blocks

The Ctrl-Alt-Del button will reboot the machine, but there is no effect from any
other keystrokes. After a supported reinstall, the VNC console boots into a
login prompt.

Is there anything I might fix to keep the VNC function after an iPXE install?
Any ideas how to debug what is stuck? I'd ask the hosting company, but, of
course, they don't support custom ISOs... I don't think I can use this custom
installation method if I have to give up the error recovery options via the VNC
I don't see how this is related to iPXE?
After installation of an OS nothing is left of iPXE anyway.

try to figure out what their vms are running on, qemu XEN, Hyper-V, Vmware or whatever, and try to go from there and find out what is _actually_ happening in that console.
And ISO is not relevant either.
Reference URL's