iPXE discussion forum

Full Version: Why Esxi 6.5 or 6.7 fail to start setup GUI via iPXE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
So what exactly happens when it fails?
possible to breakdown on the failure state? trying to resolve this.
The installation procedure is stuck once screen shows "Shutting down firmware services...."
This issue should be fixed as of iPXE commit http://github.com/ipxe/ipxe/commit/1832f8a9b

I still hit the same issue. The procedure is hang at
Shutting down if firmware services...
Using 'simple offset' UEFI RTS mapping policy
I am sure the ipxe.efi is compiled from the latest code.
I have been fighting the same thing.

I have tons of Dell 13th and 14th-generation servers that work just fine with iPXE (snponly.efi) and UEFI (Windows/Linux/ESXi). But recently I started evaluating a Lenovo ThinkServer SR630 and was experiencing the same thing. ESXi 6.5, 6.7 and 7.0 would just hang at the Shutting down firmware services message.

I saw that UEFI-related fix that was committed for and which mcb is referring to, but I would continue to have the same issue, even with a newly built iPXE binary that included the fix.

When I enable Legacy BIOS mode I don't have any issues installing ESXi via iPXE, i.e. using undionly.kpxe.

I tried a signed versions of snponly.efi and guess what? It worked. I used an older signed version from VMware's autodeploy ZIP file (I posted in another thread about which file to use). So it didn't necessarily need the fix that mcb was referring to - in fact that fix did not solve the issue for me. Only a signed version of snponly.efi did. And Secure Boot was disabled in the firmware configuration, but it still for some reason required a signed iPXE binary.
Are you saying snponly.efi is fine in UEFI BIOS and unionly.kpxe is fine in Leagcy BIOS?
anyway, snponly.efi is lower performance than ipxe.efi. The size of the two files are different as well. It looks like snponly would lose some of feature than the other one. It also looks like the difference between them are native drivers.
Anyway, ipxe.efi shall work. Not sure why iPXE prodives snponly.efi and ipxe.efi at the same time.
My point was not really about snponly.efi vs ipxe.efi.

The thing I noticed was that when I used a signed iPXE binary for UEFI booting, I did not have this issue. No change to iPXE scripts or anything else was required. Just replacing the iPXE.efi file with a signed one did the trick.

It seems that mboot.efi is able to load the modules into memory just fine, but when it tries to hand control over to the actual kernel, things break down - on some hardware, but not all. As I said, I don't have an issue with Dell servers, but with Lenovo I do.
A few days later... some additional info: I have resolved the hanging on my hardware.

I had been building snponly.efi on Ubuntu 16. I now built it on Ubuntu 20 and it works. I am briefly getting the message, then a blank screen, but then the ESXi installer GUI comes up and the install proceeds.
Pages: 1 2
Reference URL's