iPXE discussion forum

Full Version: boot iso XP legacy
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all !
I have a problem to boot Windows XP isos on computers in legacy mode with ipxe. I have an error message: memdisk bootstrap too large to load.
No problem with other installations with wim files.
Can you help me?
Thank you!
Booting the Installation ISO isn't what you need to be doing. You need to be booting WinPE v1.2 or BartPE, mounting an installation point, and then running %installation_drive%\%extracted_os_folder%\I386\winnt32.exe with command switches...

You might want to visit https://www.nliteos.com/ for more information....
Try using https://ipxe.org/wimboot instead of memdisk.
MultimediaMan, with my winpe (2.0 it seems to me), when i run winnt32.exe, i get an error message: no system partition was found.
When I run the setup.exe, the line to install XP is grayed out.
While booting on bartpe, I come across a blue screen ...
Can you tell me where to find a winPE 1.2?
Thank you!
With WinPE 1.2 or WinPE 2.0 when running winnt32.exe it assumes that you have first created a formatted partition...


You can write a simple script to do this:
#REM partition + format script as format-me.txt
select disk 0
create partition primary
format quick fs=ntfs label=SYSTEM
assign letter=c

diskpart /s format-me.txt

It goes without saying the above script is rather permanent in it's effects without some other 3rd. party disk tools...

Then try wint32.exe...

If you have to load OEM drivers for a Disk controllers your WinPE AND your Windows XP Installation Point must have them slipstreamed in.
the diskpart sees my disk well, I do the commands, but I still get the same error message.
Thank you in advance for your help!

try "winnt32.exe /syspart: c" or "winnt32.exe /syspart c:"
with the syspart command, it goes a little further but afterwards I have another error message as to convert the disk from basic to dynamic, which I did in diskpart but it doesn't work ...
whether on physical machines or hyper-v virtual machines
I have something new.
I recreated a winpe image with adk under windows 8.
This time when I run winnt32 I can start the installation, as the screenshot shows :
[Image: dq02.png]

BUT after 2 or 3 minutes I automatically come back on the winpe command prompt ...
That progress: If you dir the C: drive, what do you see?
this is what I get when the installation goes back to the winPE :

[Image: fdrm.png]

whether on physical machines or hyper-v virtual machines
I found a solution. I am using WinNTsetup4 which I run from winPE and it works. I don't know what else he does but it works so I won't look. Thank you for helping me !
Reference URL's