iPXE discussion forum

Full Version: iscsi: operation not supported
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've tried a heap of different approaches to connect to my iscsi target, and nothing seems to work. I can connect to it fine form my other initiators.

if I type:

dhcp net0
sanhook iscsi:

I get the error: "Could not open san device: invalid argument"

If I quote the iqn:

dhcp net0
sanhook "iscsi:"

I get the error: "Could not open san device: operation not supported"

The dhcp is successful and like I said I can connect to lun 0 on that target without auth on my other devices. The ipxe build says it supports iscsi when it boots.

Thanks in advance.
When you get that error message, it is usually accompanied with a URL with a hex number in it. If you post those as well, we might be able to help you a bit more, as they contain quite important debugging details. You should of course also have a look at them and look at the bottom in the troubleshooting section of each of them.

To my knowledge, the target IQN should not be quoted. I'm not sure if it's even supported.
Hey robinsmidsrod,

Yeah the reason it wasn't working was I didn't have an initiator-iqn set. For some reason I thought this option defaulted, turned out, that at least in my case this wasn't so. When I set the initiator-iqn in my dhcp hardware address entry it worked like a charm.

Thanks to the developers of ipxe, it's a brilliant piece of software, made deploying a iscsi san a breeze.

You can set the initiator-iqn based on some kind of pattern in an iPXE script conditionally, based on availability of certain attributes, like hostname, uuid, asset tag or mac.

I do that in my iPXE native menu shown here: https://gist.github.com/2234639

You'll need an updated iPXE for the menu feature, it just landed yesterday. The isset feature has been around for a long time.
Reference URL's