iPXE discussion forum

Full Version: Over riding DHCP options from windows Server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys

I was wondering if anyone could help me with this, hopefully its a tap in as I am a complete Ipxe noob - but this has been driving me mad for a few days so any feedback would be much appreciated!

Basically the firm I work for is looking at deploying a FOG server for deployment, this is obviously PXE based.

The catch is (there is always one!) that we already have a PXE service on our network, so our dhcp servers are already banging out the DHCP options for this, not FOG.

After looking at various option the best soluition is to (if this is even possible) use a USB stick/CD to boot clients when needed, pointing them at the fog server with DHCp options 66 and 67.

I have set up a lab for this, fog is set up fine, all fine when DHCP options 67 and 66 are on the server, PXE up > finds fog - all gravy.

With ipxe I am testing off a VM, I am basically trying to overide the DHCP options so that clients will ignore the server options (but get a real IP address) and add in the fog one's. All goes fine when options 66/67 are not set on the server - ipxe boots, dhcp gets an address, then I go in to the config, add the pxe/next server options, load pxelinux.0 and boot - this works fine.

The problem is when I add some false settings for the dhcp server (to mimic the already in place service) in which case fog just fails to load, I am obvioulsy manually taking out the old settings (both through CLI and the config) but (for whatever reason) some of the original settings from DHCP are overiding the settings. For some reason it just cannot find the pxelinux.0 image. edit - wont let me upload an image.

txt lines along the theme of:

TFTP Prefix:
Trying to load: pxelinux.cfg/e132a34f-xxx-xxx-xxx
Trying to load: pxelinux.cfg/e132a34f-xx-xx-xx-xx-xx-xx-xx
Trying to load: pxelinux.cfg/default
unable to locate config file.

To shorten the above novel:
Ipxe dhcp address with correct settings - fine
Ipxe dhcp with no settings 66/67 from DHCP, next server and imagename added manually fine
DHCP with incorrect options, manually edited in Ipxe - fails.
It seems like you might need the PXELinux base/config override settings, as shown in my example of loading SystemRescueCD here: https://gist.github.com/2234639#L123
You can use a proxyDHCP to send only PXE values... like bootfilename

For windows only proxyDHCP is from Serva.


Or you can use my How to...

Reference URL's