iPXE discussion forum

Full Version: Compile problem?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm a bit new, but when I run my own version of the compiled "undionly.0", I get a screwed up frozen screen. Here is my procedure:

Ubuntu 12.04 desktop - 64bit (on Hyper-V) - latest updates as of 5/31/12

> git clone git://git.ipxe.org/ipxe.git
> cd ~/ipxe/src
> vi boot.ipxe

> make EMBED=boot.ipxe bin/undionly.kpxe NO_WERROR=1
> cp bin/undionly.kpxe /tftp/undionly.0 :
prompt --key 0x02 --timeout 2000 Press Ctrl-B for the iPXE command line... && shell ||

If I run the demo, it boots... but this does not...

Unfortunately the image is unavailable, so I can't see what's going on. You shouldn't need the NO_WERROR=1 workaround anymore, as the compilation problem with newer gcc has been fixed.

I would suggest you report the problem to the mailing-list, as you might've found a bug (possibly related to Hyper-V).
As robin said the screenshot is unavailable so I can only guess where you get the frozen screen.

If it freezes after DHCP and right after iPXE tries to execute your embedded script it might also be a problem with your script.

You might run into problems if you saved your script in an incorrect encoding(UTF16, ...).

In this case iPXE will misdetect your script as an PXE executable which leads to the freeze.

You can check if this is the case by entering the iPXE console(CTRL+B), and executing the 'imgstat' command.
It should say "[Script]" for boot.ipxe. If it says anything else, check if any of the issues mentioned above apply.

Edit: Removed incorrect statements about iPXE misdetecting the image if there are whitespaces after the "#!ipxe" string.
Reference URL's