iPXE discussion forum

Full Version: ipxe with http won't work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys,

I'm trying to set iPXE up.
My Setup:
- Centos6.latest
- ISC DHCP 4.1.1
- lighttpd 1.4
- syslinux 5.0.1 (from sources)

===== /etc/dhcp/dhcpd.conf =====
option domain-name-servers;
default-lease-time 600;
max-lease-time 7200;
ddns-update-style none;
log-facility local7;
allow booting;
allow bootp;
option option-128 code 128 = string;
option option-129 code 129 = text;
subnet netmask {
option routers;
option subnet-mask;
option broadcast-address;
if exists user-class and ( option user-class = "gPXE" or option user-class = "iPXE" ) {
filename "";
} else {
filename "undionly.kpxe";

===== =====

here's what I get: http://i.imgur.com/DuIFLHJ.jpg
it seems that it PXEs, then hands it over to iPXE, then goes back to PXE??

my http server logs are:

"GET /pxe//ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe//boot/isolinux/ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe//isolinux/ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe//boot/syslinux/ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe//syslinux/ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe//ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"
"GET /pxe/ldlinux.c32 HTTP/1.0" 404 345 "-" "gPXE/1.0.0"

why does it not boot from the "default" file served?

First of all, I see in that screenshot that your undionly.kpxe is actually gPXE, not iPXE. You should replace that one, as gPXE is no longer maintained.

If you want to load .c32 modules from syslinux version < 4 directly from iPXE you need to enable the IMAGE_COMBOOT parameter in src/config/general.h and recompile. It is no longer part of the default build.
Reference URL's