iPXE discussion forum

Full Version: WinRE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

i boot a Winre.wim file from my server, with this script


cpuid --ext 29 && set arch amd64 || set arch x86
kernel wimboot
initrd ${arch}/ISO/bootmgr       bootmgr
initrd ${arch}/ISO/boot/bcd      BCD
initrd ${arch}/ISO/boot/boot.sdi boot.sdi
initrd ${arch}/Winre.wim         boot.wim

The image boot. when i run the "c:\windows\system32\bmrui.exe" it crash with

"The system can't find the file. (0x800700002)"

How can i run "bmrui.exe"?
I suggest you look in the appropriate windows system log or run a debugger tool to figure out what file it is looking for. If that file is not on the mounted volume, there is your clue. Not all ISOs or WIMs can be network-booted without issues.

Also, where did you get winre.wim from?
(2013-02-27 08:37)robinsmidsrod Wrote: [ -> ]Also, where did you get winre.wim from?

The winre.wim is from a repair disk generated by windows 7.
Are you sure the winre.wim is supposed to work in standalone mode, and that the ISO generated doesn't contain more files needed after the .wim is booted? If so, it wouldn't be easy to make it work properly with iPXE/wimboot.
Reference URL's