iPXE discussion forum

Full Version: efi_image_exec
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I was trying to chain boot an efi image.
My setup is all like traditional PXE with snponly.efi as the PXE file.

While chainloading an EFI file, I always fail at last_opened_snpdev() as it internally tries to find a PCI SNP device which it does not find. Is the problem here itself ??

Or what I understood that this can be the case as this is a software interface with no PCI address. To fix that I tried installing the protocols onto a new handle (initially NULL) and then loading the image, however the image never finds any files to read. So I tried doing this on the efi_image_handle itself. And this failed again with none of these protocols even being found on the device handle of the new image.

Any suggestions??

UEFI support is still not complete. I suggest you discuss this issue on the developer mailing-list.
Reference URL's