iPXE discussion forum

Full Version: Computer hanging at iPXE initialising devices...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
On HP dc5000 computers iPXE hangs at "iPXE initialising devices..." whenever a build a non-standard PXE bootstrap loader image from rom-o-matic.eu

By "non-standard", I mean when I select the advanced mode on the rom-o-matic.eu website, select any PXE bootstrap loader image target (.pxe, .kpxe, .kkpxe, .kkkpxe) but leave all the other options at their default setting. If I select the undionly.kpxe standard build, the computer boots fine.

However, I need a .kkpxe image because I'm chainloading from PXELINUX and passing the boot script name with the cached DHCP response.

If I boot directly to ipxe.kkpxe (bypassing PXELINUX), the computer hangs the same way.
(2013-08-07 15:45)blanalex Wrote: [ -> ]However, I need a .kkpxe image because I'm chainloading from PXELINUX and passing the boot script name with the cached DHCP response.

I have no idea what you're trying to say here. Could you show us some configuration and what files you're using?

If you're using ipxe.pxe, then you're using native drivers, and most likely the bnx2 driver (which I assume your machine is using) doesn't work properly. The only reason undionly.kpxe works is because you're using the vendor PXE drivers.
I've tried with the UNDI, UNDIONLY and all-drivers builds, they all hang at the same place. But I guess there's something broken with rom-o-matic: undionly.kpxe weights 65kB and ipxe.kkpxe with the UNDIONLY driver is 340+ kB. It seems rom-o-matic always builds with all the drivers

For the chainloading:
I use pxelinux.0 4.07 with the following configuration:
    MENU LABEL ^8 - WinPE 3.1 (CPU =P4)
    com32 pxechn.c32
    APPEND ipxe.kkpxe -o 67.s=ipxe/winpe31.ipxe -W

I can't use gpxelinux.0 because it conflicts with pxechn.c32. If I use gpxelinux.0, pxechn.c32 can't alter the cached DHCP response for the next NBP (in my case, iPXE or wdsnbp.com):
    MENU LABEL ^B - SCCM 053dp1
    kernel pxechn.c32
    APPEND\smsboot\x86\wdsnbp.com -W

I can't use use undionly.kpxe because it won't keep the cached DHCP response left by pxechn.c32.

Here's the script embedded in the iPXE binary:
set use-cached 1
autoboot net0

And here's the winp31.ipxe script:
set wimboot-path http://071srv2/wimboot
kernel ${wimboot-path}/wimboot
initrd ${wimboot-path}/bootmgr          bootmgr
initrd ${wimboot-path}/bcd              BCD
initrd ${wimboot-path}/boot.sdi         boot.sdi
initrd ${wimboot-path}/wgl4_boot.ttf    wgl4_boot.ttf
initrd ${wimboot-path}/segmono_boot.ttf segmono_boot.ttf
initrd ${wimboot-path}/segoe_slboot.ttf segoe_slboot.ttf
initrd boot.wim
I installed Ubuntu in a VM and built iPXE from scratch. It works now. I built the target undionly.kkpxe with the embedded script from above.
Reference URL's