iPXE discussion forum

Full Version: Booting via iSCSI to Debian7 on HP Server BL495c G5
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
16x BL495c G5 Blade Servers have to boot with iPXE from different iSCSI Targets. The Servers differ only in Hardware setup They all have the same Bios and the same NIC Bootrom.
i used this setup: http://backreference.org/2013/11/24/pxe-...-and-ipxe/

The Image on all Servers is the same, it was installed on Machine 1 and then cloned.
Server 1,2,5,6,9,10 are booting as suggested, all others fail.
The failing ones make the errors 'Connection timed out.' 0x4c852035
'no more Network devices'

Sometimes i get an Red Screen with the Error Illegal OpCode.

this is the part of my php code that configures the boot process:
case '00:17:a4:77:00:32':
echo "set initiator-iqn iqn.box.fritz.client:client\n";
echo "sanboot iscsi:\n";

Thanks you all Ideas.
Most likely you have a BIOS problem on the machines that don't boot properly. Check for updated firmware from HP. If that doesn't help, you might need to switch from ipxe.pxe (native driver) to undionly.kpxe (vendor driver) or vice versa. You might also have a memory map issue that can be solved by disabling support for stuff you don't need in the BIOS. Please report back if you find a solution.
After changing Blade Number 2 (boots), with Blade 3 (not booting). The Surprise was, that the before not booting Blade 3 now boots in the Slot of number 2.
And Number 2 in Slot Number 3 is not booting anymore....
So, it doesn't have to do with the Blades it self.
The Bladecenter is working with the VirtualConnect Technology.
Now i switched the Booting Lan from eth1 to eth0.
After that change in the Virtualconnect Manager, all Blades are booting now.

It seems that there is a Problem in the VC when booting from eth1.
(2013-12-29 20:28)Axel.Walsleben Wrote: [ -> ]It seems that there is a Problem in the VC when booting from eth1.

To Paraphrase an old one: If it has Tits, Tyres or Virtual Connects, you have trouble.

HP Updates their Virtual Connect firmware with frightening regularity: I interpret that to mean buggy hardware. I love HP C-series Blade Centers, don't get me wrong, but their VC concept, to me, is flawed. I just order my chassis with Cisco/HP B22 FeX Modules and call it a day.

Opinions aside, how the initial setup and permissions are set can affect how you can see (or not see) the problem. There might be a policy or a hardcoded setting you may have missed (or is hidden from you). Unless you have highest administration rights on the Virtual Connect(s), the issue may be hidden from you.
I agree, Virtualconnect is very buggy. After upgrading to Virtualconnect 4.01 the booting via iPXE stops completly. Sad
After some hours of testing i found the Solution, the Network that is used for booting, needs the feature 'Private'.
Thats solved it.
Reference URL's