iPXE discussion forum

Full Version: Install Ubuntu to iSCSI target from USB drive
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all

Trying to setup my XBMC as diskless with little success so far.

I first tried to hook the drive I wanted to install to then boot from the ISO image.

sanhook iscsi:
sanboot --no-describe --drive 0x81

This simply results in BusyBox loading, which seems to suggest that the ISO may be corrupt?

Then figured the easiest thing to do would be to boot from the USB drive as I don't plan on installing this very often.

Plugged in USB, set BIOS to boot PXE first with the following script

sanhook --drive 0x81 iscsi:
sanboot --no-describe --drive 0x80

The installer loads but when I come to select the disk to install only my USB drive is there.
I have tried with 'keep-san 1' in my script with no luck here.

Could someone point me in the right direction? Smile
Should note I am trying to install Ubuntu x64 desktop here.

Well after hours of messing around reading and trail/error

I have come to the conclusion that using a USB drive to install from isn't the best idea as this means /dev/sda1 is my USB device and /dev/sdb1 is my iSCSI volume.

Next up I investigated booting the installer properly using iPXE, the example here https://gist.github.com/robinsmidsrod/2234639 helped slightly but was still unsure on what most of the options do (in way over my head here!). After reading far too many articles I have come to the conclusion I needed to mount the Ubuntu ISO on a NFS share.

Did this as followed...
mkdir /mnt/iso
mount ubuntu-desktop.iso /mnt/iso

Added the following to /etc/exports
/mnt/iso/  *(no_root_squash,rw,async,no_subtree_check,insecure)

Can browse this successfully from my Mac by going to nfs://

Then copied vmlinuz.efi and initrd.lz from the casper directory to my HTTP server.

Then attempted to use the following iPXE script to get the installer started.

kernel boot=casper netboot=nfs nfsroot= initrd=initrd.lz

I seem to get to the start of the installer as the screen resolution is now 1920x1080 and it has detected the two onboard NICs, but am getting an issue where it gets stuck at the following...
Seems that the DHCP isn't picking up an address?

[Image: pxe.jpg]

(Please excuse the poor picture, my phone has a terrible camera)
I'm not sure, but I don't think you can use vmlinuz.efi in a legacy BIOS environment. Also, if you're not getting a DHCP response, try to do a packet capture to see if the machine is even sending one. http://ipxe.org/howto/pcap
Reference URL's