iPXE discussion forum

Full Version: Booting Pmagic iso
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello ,

I am trying to boot PMagic from iso but i get
[undefined=undefined]searching for PMAGIC_2014_04_28.SQFS[/undefined]

and finally failed
my code is as follows
sanboot http://${fog-ip}/${fog-webroot}/service//ipxe/PMagic/pmagic_2014_04_28.iso
goto MENU

I also tried
initrd http://${fog-ip}/${fog-webroot}/service//ipxe/PMagic/pmagic_2014_04_28.iso
chain memdisk iso raw ||
goto MENU

any idea how to make it work ?
Please advice
Hi tbaror,

i'm facing the same problem.
Tried different code but run into a kernel panic or a missing of the sqfs file.

kernel http://${fog-ip}/fog/iPXE-Boot/pmagic/bzImage64
initrd http://${fog-ip}/fog/iPXE-Boot/pmagic/initrd64.img
boot || goto failed
goto MENU

Go anyone PartedMagic working with ipxe?
PMAGIC_2014_04_28.SQFS is most likely a squashfs filesystem, which in that case must be loaded from the initrd over the network. Just booting the ISO will not work in this case. You'll need to look into the docs or the initrd for these tools and figure out how to specify in the kernel command line how to fetch the squashfs file over the network.

If the initrd is based on debian you might have luck by extracting the kernel+initrd from the iso and using fetch=http://server/path/to/PMAGIC_2014_04_28.SQFS on the kernel command line.

Same goes for parted.
I think you should keep the files on a NFS Server. That works in most cases for me.

KERNEL /images/iso/tools/gparted_live_0.19.1_i686/vmlinuz
INITRD /images/iso/tools/gparted_live_0.19.1_i686/initrd.img
APPEND quiet boot=live noswap noprompt nosplash vga=791 netboot=nfs nfsroot=192.168.xxx.xx:/tftpboot/images/iso/tools/gparted_live_0.19.1_i686/disk --
Just a note to anyone finding this through search engines. That last code from KingBonecrusher is PXELinux syntax, not an iPXE script. Lowercase KERNEL and INITRD and change "APPEND" to "imgargs vmlinuz".

I use the following code

initrd http://serverip/pmagic_pxe_2014_06_10/pmagic/initrd.img
initrd http://serverip/pmagic_pxe_2014_06_10/pmagic/files.cgz
chain http://serverip/pmagic_pxe_2014_06_10/pmagic/bzImage edd=on vga=normal

If I remember correctly, pmagic has a PXE version with the filesystem and necessary files inside files.cgz.
I've checked now and for gparted I have "fetch=http://serverip/gparted.squashfs" as a kernel parameter.
Reference URL's