iPXE discussion forum

Full Version: Installing Win 8.1 64 Bit via iPXE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm trying for days now to get my pxe boot environment working.

I have a dnsmasq server which pxe boots to a syslinux menu where you can select different images (working fine).

The menu calls the following:
APPEND dhcp && set image win81 && chain http://install.local/default.ipxe

To say it first the images / extracted files work fine if used on CD...

In the default.ipxe I tryed different configs:

set boot-url http://install.local/

sanboot --drive 0x81 --keep --no-describe ${boot-url}os/Win81.iso
--> Error /Boot/BCD is missing

sanboot --no-describe ${boot-url}os/Win81.iso
--> I/O error

set dir ${osdir}Win81/
kernel ${boot-url}_boot/wimboot
initrd ${dir}bootmgr bootmgr
initrd ${dir}boot/bcd BCD

initrd ${boot-url}_boot/fonts/chs_boot.ttf fonts/chs_boot.ttf
initrd ${boot-url}_boot/fonts/cht_boot.ttf fonts/cht_boot.ttf
initrd ${boot-url}_boot/fonts/jpn_boot.ttf fonts/jpn_boot.ttf
initrd ${boot-url}_boot/fonts/kor_boot.ttf fonts/kor_boot.ttf
initrd ${boot-url}_boot/fonts/segmono_boot.ttf fonts/segmono_boot.ttf
initrd ${boot-url}_boot/fonts/segoe_slboot.ttf fonts/segoe_slboot.ttf
initrd ${boot-url}_boot/fonts/segoen_slboot.ttf fonts/segoen_slboot.ttf
initrd ${boot-url}_boot/fonts/wgl4_boot.ttf fonts/wgl4_boot.ttf

initrd ${boot-url}_boot/fonts/malgunn_boot.ttf fonts/malgunn_boot.ttf
initrd ${boot-url}_boot/fonts/meiryo_boot.ttf fonts/meiryo_boot.ttf
initrd ${boot-url}_boot/fonts/meiryon_boot.ttf fonts/meiryon_boot.ttf
initrd ${boot-url}_boot/fonts/msjh_boot.ttf fonts/msjh_boot.ttf
initrd ${boot-url}_boot/fonts/msjhn_boot.ttf fonts/msjhn_boot.ttf
initrd ${boot-url}_boot/fonts/msyh_boot.ttf fonts/msyh_boot.ttf
initrd ${boot-url}_boot/fonts/msyhn_boot.ttf fonts/msyhn_boot.ttf
initrd ${dir}boot/boot.sdi boot.sdi
initrd ${dir}sources/boot.wim boot.wim

--> This config works for the 32Bit version fine but for 64 Bit the Bootloader starts (Loading Files) and then stops with a black screen.

I have a bit of technical experience but I'm pretty new to the whole pxe booting topic.
I tried to get some kind of debug output but totaly failed as I'm not even sure where the setup failed.
What I already tried is to change the bootmgr and afterwards the whole boot folder from the working 32 Bit install -> no success...

I also managed to get the install.wim instead of the install.esd - I changed the files but no change / same behaviour.

I would be happy if somebody could point me in the right direction.

BTW I know that I can boot a Winpe image and start the install from there but that's not what I would like to have - I would like to directly boot to the setup as if the cd would be in the machine.

Thanks in advance for any help
Are you trying this out in a virtual machine? I've noticed that WinPE 5.0 (the one based on Win8) crashes my VirtualBox (4.3.12). WinPE 4.0 works without issues.

You should download the latest version of wimboot and try out the simplified ipxe script (no need for fonts and bootmgr anymore) and see if that works better for you.

You can find details on how to start the installer directly using a batch file in this howto: http://ipxe.org/howto/winpe
Reference URL's