iPXE discussion forum

Full Version: When initrd WinPE.wim IPXE hung up
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
We meet a problem for Intel 219-LM lan chipset when the unit boot from iPXE Legacy model with undionly.kpxe, it always hung up when initrd WinPE.wim, sometimes also show timeout when initrd BCD, i also tried undionly.kkpxe, it also hung up, but the same unit can boot sucessful from UEFI model with snponly.efi

Who can help solve this issue? or tell us how to debug this issue? Many thanks,
Have you tried adding a PCI_ROM() line for your i219LM in src/drivers/net/intel.c and booting with intel.pxe/ipxe.pxe instead of undionly.kpxe? Could you also post a screenshot of when the error occurs?
From ipxe command line the command should be : boot http://my.server.com/winpe/boot.ipxe . If it does not work, use the command dhcp to ensure you have connectivity. if dhcp does not work, then ipxe did not manage to load the correct network drivers (try then the full ipxe version, not just the undi-only one).

I add PCI ID into intel.c and test result as bellow,
1. undionly.kpxe: hang up, hang up stepping random, maybe initrd BCD, maybe initrd boo.wim, the percentage is also not sure.
2. ipxe.pxe: hang up with "TFTP Download: boot\undionly.kpxe"
3. intel.pxe: can boot sucessful, but speed very slowly, 200MB wim file, about need 5 minutes.

for screenshot, it seems like i have no permission. I will send them to you with Email, thanks,
Not trying to step on any boundaries or anything, but if it's requesting a load out to boot\undionly.kpxe it seems, to me, that it's attempting to boot from UEFI/EFI methods which wouldn't work for the undionly files. You'd need to use snp.efi, snponly.efi, or ipxe.efi.
oh, many thanks for mcb30 support, this solution is fine, thanks,
Reference URL's