iPXE discussion forum

Full Version: Windows 8 iSCSi Boot - INACCESSIBLE_BOOT_DEVICE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
We are trying to boot Windows 8 from an iSCSI target. I have an i7 based diskless client. I used its PXE ROM to boot iPXE according to these steps:

After iPXE loads I use a .ipxe script on my Web Server to have wimboot run and I can connect to and install Windows 8 (after patching my NIC driver into boot.wim and install.wim) to my iSCSi target as outlined here:

After Windows 8 installation to my iSCSI target my PXE rom boots iPXE, connects to the iSCSI SAN, then proceeds to boot Windows 8 from my iSCSI target. Just before I get to screen where I would expect Windows to ask my the final questions about users and computer name I get what appears to be a BSOD with INACCESSIBLE_BOOT_DEVICE (Your PC ran into a problem and needs to restart. If you'd like to know more,you can search online later for this error: INACCESSIBLE_BOOT_DEVICE).

Can somebody PLEASE tell me what I might need to do? Do I need to somehow get some iSCSI initiator drivers into my Windows 8 install.wim image?

The install process is 1st stage: winpe, reboot, 2nd stage: winpe from install.wim, reboot, 3rd stage: finishup.

My guess is that it fails on the second step, the reason for it being that the nic drivers didn't actually install (normally the network drivers are install at the end of stage 2) for iSCSI to work it must be installed in the image att stage 1.

I don't know how this should be done, or if it is the real culpit.
Could you test doing an installation to physical hd and after the first reboot press Shift+F10 Type compmgmt.msc and check if the nic is installed.
If not you atleast found why.
Did anyone find a resolution to this? I'm having the same problem with Windows 10. It's strange that none of the Windows iSCSI install tutorials mention this, but I've found several posts from people having the same issue. There must be something to it...
Installing Windows 7, 8 and 8.1 to iSCSI should work without issues by following the http://ipxe.org/howto/winpe tutorial with a proper sanhook command before the boot command. Windows 10, unfortunately, has an issue making it troublesome to install to an iSCSI target.

hairlesshobo mentioned a while back on IRC that the following workaround might make it work:
Quote:I did a install to local HDD, switched start type of msiSCSI server to 2 (from 3), disabled lightweight filter driver on NIC, cloned to iSCSI disk and tada, win10 boot
Reference URL's