iPXE discussion forum

Full Version: Cannot flash Intel nic: "invalid image file"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to flash an intel nic with iPXE. I have been following the docs and got my nic ID (80861502) made the rom, downloaded bootutil, booted freedos but the -restorimage command fails with the error "Invalid image file"
I found on the forums to check the ROM image size and I can see the rom created from make is 65K which appears correct and I also saw recommendations to try older versions of bootutil. I tried versions 18.3, 19, 20, and 21 and all give the same error. I haven't tried flashrom but am begining to think there may actually be something wrong with my rom.

How can I verify I have a good image and does anyone have suggestions for where to look next to get the rom flashed?
Did you see this forum thread: http://forum.ipxe.org/showthread.php?tid=3420 ?
I'm not sure how I missed that thread in my searching. I just tried but ibautil says

ERROR: No supported network adapters found
I did a few more tests after some more reading and at first tried just renaming the .rom file to bootimg.flb just in case. That didn't work which just proved the flb file format is different than the .rom file. That lead me to this thread which I think I'll try next.


Part of me isn't 100% sure why I want iPXE flashed on the NIC but now it's a challenge I'm determined to get.
I give up. I'm guessing there's a limitation on my nic because even trying to flash an official updated rom (flb) file extracted from preboot utility I get

"Option ROM area in the flash is not supported for this device on port 1"

I also tried a -RESTOREIMAGE and get

"ERROR: Failed processing FLB file for port 1"

Wondering if this is a limitation because I'm using HP hardware.
Did this ever get resolved, been banging my head on it for a while with minimal success.
Reference URL's