iPXE discussion forum

Full Version: Http Auth - Kerberos @ Download
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Everybody.
Actually we are running IPXe from TFTP through DHCP Opt 66, use a ASP Site as GUI , submit the menu to the client and retrieve from SCCM or Isos from WebServer.

We have an issue with physical clients at the retrieval from SCCM if anonymous authentication is disabled.

On virtual machines that problem does not exist as the AD-Com and Auth seems to be done through the virtualisation solution.

We tried to offer the links for an authenticated download as follows

Echo Thisisanexample
kernel http://username:Password@mysccmseerver/Package/wimboot
initrd http://username:Password@mysccmseerver/Package/boot/BCD BCD
.etc and so on.

We had no success with that.

Has anyone solved that problem yet?

Thanks for Help!
What is the actual issue you get?
If you get an error from iPXE it will show a "ipxe.org/ error url"
Please provide that url if any, also read that page.

Otherwise it would be good to provide enough information so that anyone can reproduce the issue.

The only method supported for authentication is basic http auth, so the link to Kerberos needs to be implemented by the http server.

One other thing to try is to build iPXE with debug flags enabled see http://ipxe.org/download#debug_builds

Hope that get you started on how to get further.
Reference URL's