iPXE discussion forum
DHCP failure with Intel I219-V - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: DHCP failure with Intel I219-V (/showthread.php?tid=14972)

DHCP failure with Intel I219-V - mgperkow - 2018-11-05 15:18

I have been having problems with iPXE on an HP EliteBook 840 G3, which has an Intel I219-V network adapter. DHCP configuration fails repeatedly, and if I do an ifstat from a shell, the information for the I219-V adapter indicates it is logging error 3c6540 (Operation not supported) once per DHCP attempt.

Please let me know if I need to provide anymore details.

RE: DHCP failure with Intel I219-V - NiKiZe - 2018-11-05 22:03

It is normal that ifstat shows errors, for example it wont be able to send when the link is down.

What is the actual issue you are having? is dhcp command failing? what error does it give (remember that the error url should be included in your report.)
Have you read the page (error url)?

if you are still having issues, make sure to include pciid of your nic (use lspci -nn) and which build target you are using for ipxe.

RE: DHCP failure with Intel I219-V - mgperkow - 2018-11-05 22:17

The errors are being logged once per DHCP attempt. So, if I do it manually via shell so that I can check the results with ifstat after an ifopen and a DHCP attempt, the transmission error counter will go up by 3 (and then three again if I attempt DHCP again).

Yes, DHCP fails (040ee119 / No configuration methods succeeded).

The error shown in ifstat is 3c654003. Of the two source lines referenced in the error documentation, I'm pretty certain it's happening on line 888 of intel.c.

My build is of the most recent git commit at the time of this post. It's a 386 PC BIOS ipxe.lkrn. The network device's PCI ID is 8086:1570.

RE: DHCP failure with Intel I219-V - NiKiZe - 2018-11-05 22:56

internal errors while dhcp command runs are indeed viable via ifstat - but should not be seen as erros for the dhcp command.

if you run dhcp - and that disaplays an error then you have an error. if not then everything worked as expected. regardless of any later ifstat output.

are you doing ifopen? why? just run dhcp.

you have still not posted any ipxe.org error url.

RE: DHCP failure with Intel I219-V - mgperkow - 2018-11-05 23:09

Sorry. I thought the error codes I was citing would imply the URLs (since the ipxe.org error URLs all seem to be constructed formulaically from them).

DHCP is definitely failing. Error URL is http://ipxe.org/040ee119. Message says "No configuration methods succeeded" after an attempt. It doesn't matter whether I issue ifopen before or not. I was just trying it a few different ways to see if anything happened differently. But, if I do nothing but issue dhcp, it fails with the aforementioned error.

The error URL I'm seeing if I do an ifstat after an attempt is http://ipxe.org/3c654003. I figured that might be relevant so I included it.

RE: DHCP failure with Intel I219-V - NiKiZe - 2018-11-05 23:15

so that error url has lots of information on exactly what to try.
yes the url is created from the full error code, but it takes unnecessary time to write it, and does not help if you don't know that is the way the url is created. (you and me are note the only ones that will read this)
so ALWAYS include the error url.

It also seems that you haven't gone thru the checklist on that pagr.

RE: DHCP failure with Intel I219-V - mgperkow - 2018-11-05 23:28

Forgive me, I feel Iike I'm out of my element in this venue, perhaps. I'm trying to interact as successfully as I can...

The checklist on http://ipxe.org/040ee119? Let me see...

- I am using the latest revision (HEAD from the git repository). Or does it mean to try the latest RELEASED version?

- I think the developers read these posts, right? Or should I contact them via another means?

- I will recheck the error page regularly in case it is updated.

- I don't think it's a timeout on the part of the DHCP server. If I reboot to an installed OS or boot from a USB drive without changing anything, DHCP succeeds immediately.

- I am not using IPv6.

- I have run an ifstat after the failures. The RX and RXE counters are both 0.

- I can try ifconf for DHCP explicitly if you wish, but that's the only method that would succeed anyway on this particular network if any did (no IPv6, as I mentioned).

- I am not chainloading undionly.kpxe (using ipxe.lkrn).

- I am using a Cisco switch, and portfast is enabled.

RE: DHCP failure with Intel I219-V - scan80269 - 2018-11-06 06:53

Are you doing legacy (BIOS) PXE boot or UEFI PXE boot with the Elitebook 840 G3?

If I recall correctly, the HP Elitebook 840 G3 defaults to UEFI mode, which corresponds to UEFI PXE boot (IPv4 and/or IPv6), so a UEFI PXE boot to ipxe.lkrn may not get very far...

I recently have very good luck running ipxe-snponly-x86-64.efi (built using ROM-O-Matic) with several Intel NUC PCs booting with UEFI PXE. When UEFI iPXE loads and my script runs, I see a "link down" line and another line with "TX:0, RX:0" briefly, but then the script quickly moves on to successful sanboot of an iSCSI target, so I've been ignoring those lines indicating the link not working.

Also, I'm using Tiny PXE Server to support iPXE, with proxyDHCP enabled, as I have a wireless router in home network acting as DHCP server. OS is Windows Server 2016.

RE: DHCP failure with Intel I219-V - mgperkow - 2018-11-06 14:00

Yes, the 840 G3 does default to UEFI, but I am doing a BIOS / Legacy boot. Unfortunately, what I'm doing requires a BIOS boot.

I'm reasonably certain this is some sort of driver glitch. Looking through the intel.c source code in iPXE and reading past posts (both on this forum and elsewhere on the Internet), it seems like the I219 series adapters have had a history of presenting problems time and again. Indeed, I've successfully used this same iPXE binary with about half a dozen other network adapters where I work. The I219 is the first one that has given me such significant problems.

RE: DHCP failure with Intel I219-V - scan80269 - 2018-11-20 02:20

Not sure if this can help, but I've noticed that Intel keeps adding additional flavors of I219-V (and I219-LM), with different device IDs. Looking at the latest Intel LAN driver (e1d65x64.inf,, 10/10/2018), they have gone to "Intel ® Ethernet Connection (9) I219-V" (ditto for I219-LM). I bought an Intel NUC8i7BEH PC a few days ago and discovered it has "Intel ® Ethernet Connection (6) I219-V", which is not supported by the inbox Intel LAN driver that comes with Windows 10 1803 (RS4, build 17134). I was trying to install this OS over the network into an iSCSI disk for this NUC8i7BEH, and ended up having to manually inject the latest Intel LAN driver into the install.wim of the Win10 installation files, as well as for WinPE.

I did have an HP EliteBook 840 G3 for about a year before it got replaced a month ago, and unfortunately I did not note the flavor of I219-V this notebook had. If you can identify the PCI VEN & DEV IDs of the Intel LAN in the 840 G3, it should be possible to check which of the I219-V it has, i.e. "Intel ® Ethernet Connection (?) I219-V", then check whether the legacy PXE driver has caught up to supporting that I219-V flavor. I just checked ROM-o-Matic and the drop-down menu for NIC driver selection does not go beyond I219V-5.

In short: Intel I219-V is not just I219-V as there are now at least 9 flavors each with unique PCI VEN & DEV IDs, and they may not all be supported by the legacy PXE driver unless the code undergoes a systematic update to add the recent IDs.

RE: DHCP failure with Intel I219-V - mgperkow - 2018-11-26 15:57

Yes, I've come to a similar conclusion. I was looking through some of iPXE's Intel network driver source code myself, and it looks like a number of special configuration tweaks have been added for the I219 adapters. I played with the code a little bit (mostly tried changing certain flags), and tried some specialized builds of iPXE, but I couldn't get it to work with the I219 adapters that are troubling me. Although I'm a pretty experienced programmer myself, I have little experience with driver development, and I'm rather out of my depth in trying to fix a problem like this one. I'll probably just have to wait until (hopefully) the iPXE developers are able to add support for newer versions of the I219 network adapters.

RE: DHCP failure with Intel I219-V - burinot - 2020-10-02 09:59

Hi all,

The error shown in ifstat is 3c654003. Of the two source lines referenced in the error documentation, I'm pretty certain it's happening on line 888 of intel.c.