iPXE discussion forum
iPXE efi to chainboot - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: iPXE efi to chainboot (/showthread.php?tid=15141)

iPXE efi to chainboot - bburk - 2018-11-19 18:22

So, ultimately I'm trying to get a Macbook Pro to download a windows image from my custom DHCP/TFTP server. I can distinguish macs, and get them to download a file to boot from. Downloading the windows bootloader EFI directly isn't working, so tried grubnetx64.efi and now ipxe.

So, I created an efi using the steps here:

make bin-x86_64-efi/ipxe.efi EMBED=chain.ipxe

where chain.ipxe is defined as below to force it to use TFTP rather than HTTP, based on information here:


set next-server
chain tftp://$(next-server)/bootx64.efi

I can serve the ipxe.efi file I compiled jsut fine, but things pretty much just stop there.

it says

"iPXE initializing devices... ok

iPXE 1.0.0+(133f)

and then just stops. Wireshark shows no network messages subsequent top the TFTP download of ipxe.efi, DHCP or otherwise, so clearly hasn't started running the script.

(as an aside, this is similar to what grubnetx64.efi was downing.. download the base bit, then broke into a shell instead of trying to download the menu conf file, etc.)

Any suggestions?

RE: iPXE efi to chainboot - NiKiZe - 2018-11-28 16:24

Have your tried to run snponly.efi?
Could you also please try and grab the pciid of the nic in the machine, also search the forum for that pciid (recommended linux command is lspci -nn)