iPXE discussion forum
EFI + IPXE woes - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: EFI + IPXE woes (/showthread.php?tid=22581)

EFI + IPXE woes - StormTiberius - 2020-05-10 23:22

Hello, i am relatively new to network booting and such but i have made some progress.

My main problem is that i am unable to boot ipxe without CSM module aka in EFI mode.

There appears to be no way to flash my laptops realtek nic without bios file modification so i am left with chain loading.

Everything should be fully operational on the server side i am able to chain boot undionly.kpxe when i use bios mode and winpe loads and i am able to install windows.

However i have hit a wall with ipxe.efi all i get is generic bios message "Setup Warning Boot Failure."

The only way i have managed to launch ipxe in EFI mode is when i downloaded and booted EFI shell from USB stick and directly launched ipxe.efi.

Even when i tried to boot ipxe cd it only resulted in the same error message.

At this point i am starting to think that this may be a bios issue but whatever suggestions you may have would be much appreciated.

RE: EFI + IPXE woes - NiKiZe - 2020-05-14 05:48

is secure boot disabled?
Have you made sure that your setup are correctly configured to handle the efi network boot scenario (especially sending the correct binary)

You should verify your setup with a different PC, or a virtual machine

RE: EFI + IPXE woes - StormTiberius - 2020-05-14 08:09

Hello, thanks for the reply.

After further tinkering the issue was resolved, the prebuilt ipxe.efi that came from my linux distro (gentoo) repository was old or otherwise buggy and caused things to fail also had some stupid mistakes in the dhcpd.conf file because i tried various things trying to get the older ipxe.efi to boot so that being said with fresh built ipxe.efi and correct dhcpd.conf i am now able to boot to winpe in efi mode Smile