iPXE discussion forum
dnsmasq incompatibility? - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: dnsmasq incompatibility? (/showthread.php?tid=6972)

dnsmasq incompatibility? - xerces8 - 2013-07-11 10:48


I am trying to netboot a laptop that has no builtin PXE support.
I tried gPXE 1.0.1 and iPXE 1.0.0+ (9361).

After getting IP config over DHCP, gPXE prints:
No filename or root path specified
No more network devices

iPXE prints a similar message:
Nothing to boot , http://ipxe.org/2d03e13b

Apparently filename and root-path are empty (checked as described on the error page).

The cause might be some incompatibility between iPXE and dnsmasq as described here: http://etherboot.org/wiki/dnsmasq#a_potential_problem_and_a_fix

Other PCs with builtin PXE support work fine on the same LAN.

Any idea how to proceed troubleshooting? Use a debug build?

RE: dnsmasq incompatibility? - robinsmidsrod - 2013-07-17 14:54

I would suggest you use the most recent build, which you can also build using http://rom-o-matic.eu/ and use DEBUG=autoboot, maybe this will shed some light on what's going on. Obviously you should just boot into iPXE using the normal chainloading, run dhcp followed by config and verify that the next-server and filename params are there. If they are not, then you need to look more carefully at your dnsmasq configuration.

RE: dnsmasq incompatibility? - xerces8 - 2013-07-18 10:54

Thanks, I selected the ISO format on rom-o-matic, debug: autoboot and revision: master

Then run it (defaults with no user input) on the laptop and it loads the network boot stuff correctly. Therefore I did not pay much attention to the debug output.

If anyone is interested, I can throw a second look to the details.

RE: dnsmasq incompatibility? - xerces8 - 2013-07-18 21:27

Actually, I tried again the "older" versions and now they work too.
Either the boot server was having hiccups or maybe I accidentally connected the laptop to the wrong ethernet segment.