iPXE discussion forum
help with ath9k wifi card - Printable Version

+- iPXE discussion forum (https://forum.ipxe.org)
+-- Forum: iPXE user forums (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: help with ath9k wifi card (/showthread.php?tid=7540)

help with ath9k wifi card - kgrodrigues - 2014-11-28 06:22

I have a google chromebook, one of the earlier CR-48 Fish Models with an Atheros AR928X WiFi PCI-Express card.
I compiled the latest version, using http://www.coreboot.org/IPXE, but when I boot it (via a usb stick), it doesn't seem to see the Wifi card. I checked in the ath9k driver source, and it seems to support the wifi card based on the PCI ID. (168c:0022).

Anyone any ideas on how to go about troubleshooting this?
How to I make sure that the driver is included when I build an image?

RE: help with ath9k wifi card - robinsmidsrod - 2014-12-03 16:51

Actually, the PCI ID 168c:0022 is not listed in ath9k.c. There are very similar models of the AR928X (168c:002a) listed, so you might have luck by just adding a PCI_ROM() line for that particular ID. If it doesn't work, building with DEBUG=ath9k and running through the test at http://ipxe.org/dev/driver to figure out what parts work and not would be useful. Those tests are written with cabled adapters in mind. You'll need to change the instructions slightly to deal with wifi. Obviously you'll need to specify the SSID and key before opening the interface, as described on the coreboot wiki. Quite interested to hear your response.

RE: help with ath9k wifi card - kgrodrigues - 2014-12-06 09:00

I checked the PCI iD again, and it turns out it was 168c:002a. I must have miss remembered. So it really should be supported.

I built again with DEBUG=ath9k, but I dont see any difference when I boot. I was expecting to see debug messages or something else.
I tried the first few steps in the link you sent, the 'link detection' section, but the first thing it mentions using is the ifstat command. This produces nothing.

When its booting ipxe it does say 'No more network devices'. There is no net0

Could be how i'm building my ISO.
i'm doing 'make bin/168c002a.iso DEBUG=ath9k:3'

RE: help with ath9k wifi card - robinsmidsrod - 2014-12-06 21:38

Try to build using this command line:

make bin/ipxe.iso DEBUG=ath9k_ani,ath9k_ar5008_phy,ath9k_ar9002_calib,ath9k_ar9002_hw,ath9k_ar9002​_mac,ath9k_ar9002_phy,ath9k_ar9003_calib,ath9k_ar9003_eeprom,ath9k_ar9003_hw,ath​9k_ar9003_mac,ath9k_ar9003_phy,ath9k,ath9k_calib,ath9k_common,ath9k_eeprom_4k,at​h9k_eeprom_9287,ath9k_eeprom,ath9k_eeprom_def,ath9k_hw,ath9k_init,ath9k_mac,ath9​k_main,ath9k_recv,ath9k_xmit

This should enable debug for all the files related to the ath9k driver, which should hopefully give you something useful. It should be all one long line. These names are from the .c files in src/drivers/net/ath/ath9k/.

But if you boot and ifstat reports nothing, or at least not any Atheros-related hardware, then you don't have the correct driver loaded in your binary, or there is something strange going on with the PCI vendor/device IDs.

Once you have an atheros device listed by ifstat you should be able to use iwlist to find the SSID and use "set ssid XXX" and "set key YYY", followed by ifopen to associate with you wifi network. At that point a dhcp command should give you an IP address (if your SSID+key is correct).

RE: help with ath9k wifi card - kgrodrigues - 2014-12-07 02:34

tried the command line you suggested. still dont see any different behaviour.
ifstat doesnt show anything, and no debug messages on the screen

how do i make sure i have the ath9k drivers in my iso image?

looking at the iso, i have a boot folder, boot.cat, ipxe.krn, isolinux.bin and isolinux.cfg

do i need drivers for the pci express bus, etc?

RE: help with ath9k wifi card - robinsmidsrod - 2014-12-08 22:30

If ifstat doesn't list your atheros interface then you're either not using an ISO with the correct drivers, or your card is not supported, even though your information seems to suggest otherwise. Try http://boot.ipxe.org/ipxe.iso just in case you have a compilation issue. It should have drivers compiled in for the Atheros WiFi adapters.

PCIe should be supported out-of-the-box.